summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorUlf Samuelsson2007-07-12 17:28:58 +0200
committerUlf Samuelsson2007-07-12 17:28:58 +0200
commite327a1f0a76db118ef1e86041c91cee061675182 (patch)
tree983d8b0d59074a1da6c6930f844b47972dbf2a07 /Makefile
parentUpdate Instructions for applying for Buildroot write access (diff)
downloadbuildroot-e327a1f0a76db118ef1e86041c91cee061675182.tar.gz
buildroot-e327a1f0a76db118ef1e86041c91cee061675182.tar.xz
buildroot-e327a1f0a76db118ef1e86041c91cee061675182.zip
Change HOSTNAME to TARGET_HOSTNAME to avoid superseeding build host HOSTNAME
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index d32807265..9ddf17cc6 100644
--- a/Makefile
+++ b/Makefile
@@ -156,9 +156,9 @@ else
TARGETS:=uclibc
endif
-PROJECT:=$(strip $(subst ",, $(BR2_PROJECT)))
-HOSTNAME:=$(strip $(subst ",, $(BR2_HOSTNAME)))
-BANNER:=$(strip $(subst ",, $(BR2_BANNER)))
+PROJECT:=$(strip $(subst ",,$(BR2_PROJECT)))
+TARGET_HOSTNAME:=$(strip $(subst ",,$(BR2_HOSTNAME)))
+BANNER:=$(strip $(subst ",,$(BR2_BANNER)))
include toolchain/Makefile.in
@@ -238,7 +238,7 @@ $(TARGET_DIR)/etc/issue: $(TARGET_DIR) .config
echo "$(BANNER)" >> $(TARGET_DIR)/etc/issue
$(TARGET_DIR)/etc/hostname: $(TARGET_DIR) .config
- echo "$(HOSTNAME)" > $(TARGET_DIR)/etc/hostname
+ echo "$(TARGET_HOSTNAME)" > $(TARGET_DIR)/etc/hostname
source: $(TARGETS_SOURCE) $(HOST_SOURCE)