summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2010-07-26 23:53:37 +0200
committerPeter Korsgaard2010-07-26 23:57:01 +0200
commite49e2feda47fffb5e7a568a89d1f36615e75ce87 (patch)
treee6ee27a0db138571bf3ee4424da642e47f9b4bb7 /Makefile
parentiw: bump to 0.9.20 and migrate to gentargets (diff)
downloadbuildroot-e49e2feda47fffb5e7a568a89d1f36615e75ce87.tar.gz
buildroot-e49e2feda47fffb5e7a568a89d1f36615e75ce87.tar.xz
buildroot-e49e2feda47fffb5e7a568a89d1f36615e75ce87.zip
Makefile: fix ldconfig selection for internal toolchains
Commit ed0d45fdd (Choose host/target ldconfig based on availability) added a runtime check for a cross-ldconfig being available. Unfortunately this checks runs too early (at package/Makefile.in parsing time), so it always fails when using an internal toolchain as ldconfig isn't built yet. Fix it by moving the check to the only place it is used (target-finalize). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f6e02bc29..a864aae65 100644
--- a/Makefile
+++ b/Makefile
@@ -406,8 +406,12 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
endif
find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
- $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
-
+ if [ -x "$(TARGET_CROSS)ldconfig" ]; \
+ then \
+ $(TARGET_CROSS)ldconfig -r $(TARGET_DIR) 2>/dev/null; \
+ else \
+ /sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null; \
+ fi
mkdir -p $(TARGET_DIR)/etc
echo $(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion) > \
$(TARGET_DIR)/etc/br-version