summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2009-03-19 12:06:47 +0100
committerPeter Korsgaard2009-03-19 12:06:47 +0100
commite7b38c71ce55720f7709f0049f5bfc71ca0615ec (patch)
tree2ce70187ad1380f02c1777e7da3a48fb16d9f26a /Makefile
parentliboil: don't build examples (diff)
downloadbuildroot-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.tar.gz
buildroot-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.tar.xz
buildroot-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.zip
package: add STAMP_DIR and use for host builds
Move stamp (dependency) files outside the (version specific) source directories, so other packages can hardcode dependencies on them instead of having to use <PACKAGE>_VERSION variables. This is important as the variables in the make rules are evaluated when the rules is seen, which might be before the dependent makefile is parsed (and hence <PACKAGE>_VERSION variable is known, screwing up stuff. The downside of this is that the package isn't automatically rebuilt when the version changes (E.G. by a svn update) and you now also have to remove the stamp files next to $(BUILD_DIR)/<PACKAGE>-* to force a rebuild.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index fa44dc4e9..b8676bf8a 100644
--- a/Makefile
+++ b/Makefile
@@ -283,7 +283,7 @@ $(BR2_DEPENDS_DIR): .config
dirs: $(DL_DIR) $(TOOL_BUILD_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(HOST_DIR) $(BR2_DEPENDS_DIR) $(BINARIES_DIR) $(PROJECT_BUILD_DIR) \
- $(PROJECT_BUILD_DIR)/autotools-stamps
+ $(PROJECT_BUILD_DIR)/autotools-stamps $(STAMP_DIR)
$(BASE_TARGETS): dirs
@@ -295,7 +295,7 @@ world: dependencies dirs target-host-info $(BASE_TARGETS) $(TARGETS_ALL)
$(TARGETS_CLEAN) $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) \
$(DL_DIR) $(TOOL_BUILD_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(HOST_DIR) $(BR2_DEPENDS_DIR) $(BINARIES_DIR) $(PROJECT_BUILD_DIR) \
- $(PROJECT_BUILD_DIR)/autotools-stamps
+ $(PROJECT_BUILD_DIR)/autotools-stamps $(STAMP_DIR)
#############################################################
#
@@ -304,7 +304,7 @@ world: dependencies dirs target-host-info $(BASE_TARGETS) $(TARGETS_ALL)
#
#############################################################
$(DL_DIR) $(TOOL_BUILD_DIR) $(BUILD_DIR) $(HOST_DIR) $(PROJECT_BUILD_DIR) \
- $(PROJECT_BUILD_DIR)/autotools-stamps $(BINARIES_DIR):
+ $(PROJECT_BUILD_DIR)/autotools-stamps $(BINARIES_DIR) $(STAMP_DIR):
@mkdir -p $@
$(STAGING_DIR):
@@ -365,10 +365,10 @@ external-deps:
#
#############################################################
clean: $(TARGETS_CLEAN)
- rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps
+ rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps $(STAMP_DIR)
dirclean: $(TARGETS_DIRCLEAN)
- rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps
+ rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps $(STAMP_DIR)
distclean:
ifeq ($(DL_DIR),$(BASE_DIR)/dl)