summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMaxim Grigoriev2009-07-24 02:37:06 +0200
committerPeter Korsgaard2009-07-24 02:37:06 +0200
commitedb5ca9c529804c449a5ff3a11607bd26eef394b (patch)
tree37f614b545251a9de5a1401152342280af4003e7 /Makefile
parenttoolchain: xtensa toolchain patch support (diff)
downloadbuildroot-edb5ca9c529804c449a5ff3a11607bd26eef394b.tar.gz
buildroot-edb5ca9c529804c449a5ff3a11607bd26eef394b.tar.xz
buildroot-edb5ca9c529804c449a5ff3a11607bd26eef394b.zip
Makefile: apply xtensa specific TARGET_SKELETON_PATCH if available
Part of #163. Signed-off-by: Maxim Grigoriev <maxim2405@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 76dd2cdf0..f039f13d1 100644
--- a/Makefile
+++ b/Makefile
@@ -332,6 +332,9 @@ $(PROJECT_BUILD_DIR)/.root:
if [ -d "$(TARGET_SKELETON)" ]; then \
cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
fi; \
+ if [ -d "$(TARGET_SKELETON_PATCH)" ]; then \
+ toolchain/patch-kernel.sh $(TARGET_DIR) $(TARGET_SKELETON_PATCH)/ \*patch\*; \
+ fi; \
touch $(STAGING_DIR)/.fakeroot.00000; \
fi
-find $(TARGET_DIR) -type d -name CVS -o -name .svn -print0 | xargs -0 rm -rf