summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2011-09-29 21:57:38 +0200
committerPeter Korsgaard2011-09-29 22:19:08 +0200
commitee0246e1e1d83f41985489c85dfef07098a2026d (patch)
tree4f9c4ea6f5b8651b29b16ca30132a7a15af30fd2 /Makefile
parentpackage: enhance infrastructure to support source dir override (diff)
downloadbuildroot-ee0246e1e1d83f41985489c85dfef07098a2026d.tar.gz
buildroot-ee0246e1e1d83f41985489c85dfef07098a2026d.tar.xz
buildroot-ee0246e1e1d83f41985489c85dfef07098a2026d.zip
package: add configuration option to specify a local override file
The user can now create a custom local override file to override the source directory for various packages. An example override file: ZLIB_OVERRIDE_SRCDIR = /tmp/zlib STRACE_OVERRIDE_SRCDIR = /opt/strace-4.5.20 would tell Buildroot to use the zlib and strace source code from the specified directories, instead of download, extracting and patching the code has done usually by Buildroot. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a20d3e2a8..8525b7ddd 100644
--- a/Makefile
+++ b/Makefile
@@ -309,6 +309,13 @@ else ifeq ($(BR2_TOOLCHAIN_CTNG),y)
include toolchain/toolchain-crosstool-ng.mk
endif
+# Include the package override file if one has been provided in the
+# configuration.
+PACKAGE_OVERRIDE_FILE=$(call qstrip,$(BR2_PACKAGE_OVERRIDE_FILE))
+ifneq ($(PACKAGE_OVERRIDE_FILE),)
+-include $(PACKAGE_OVERRIDE_FILE)
+endif
+
include package/*/*.mk
include boot/common.mk