summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen2003-01-17 09:03:59 +0100
committerEric Andersen2003-01-17 09:03:59 +0100
commitef7784a62d2ecd681b37aee7040e71bbb34a51cd (patch)
tree92daacce553b174393de87921912ada04a4ecb6e /Makefile
parentbe sure include dir is present (diff)
downloadbuildroot-ef7784a62d2ecd681b37aee7040e71bbb34a51cd.tar.gz
buildroot-ef7784a62d2ecd681b37aee7040e71bbb34a51cd.tar.xz
buildroot-ef7784a62d2ecd681b37aee7040e71bbb34a51cd.zip
standardize handling of GNU configure scripts
-Erik
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 8e1f4d3e3..cde7e4cc2 100644
--- a/Makefile
+++ b/Makefile
@@ -55,14 +55,14 @@ BUILD_WITH_LARGEFILE:=true
WGET:=wget --passive-ftp
# Optimize toolchain for which type of CPU?
-#OPTIMIZE_FOR_CPU:=i486
-#OPTIMIZE_FOR_CPU:=strongarm
-#OPTIMIZE_FOR_CPU:=whatever
-OPTIMIZE_FOR_CPU:=$(ARCH)
+OPTIMIZE_FOR_CPU=$(ARCH)
+#OPTIMIZE_FOR_CPU=i486
+#OPTIMIZE_FOR_CPU=strongarm
+#OPTIMIZE_FOR_CPU=whatever
# Any additional gcc options you may want to include....
-#EXTRA_GCC_CONFIG_OPTIONS:=--without-float
-EXTRA_GCC_CONFIG_OPTIONS:=
+EXTRA_GCC_CONFIG_OPTIONS=
+#EXTRA_GCC_CONFIG_OPTIONS=--without-float
#############################################################
#
@@ -135,7 +135,8 @@ TARGET_PATH:=$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:/bin:/sbin:/usr/bin:/usr/
STRIP:=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
#STRIP:=/bin/true
IMAGE:=$(BASE_DIR)/root_fs
-GNU_TARGET_NAME:=$(OPTIMIZE_FOR_CPU)-pc-linux-gnu
+MAKE:=make
+GNU_TARGET_NAME:=$(OPTIMIZE_FOR_CPU)-unknown-linux-gnu
ifneq ($(strip $(ARCH)),i386)
CROSS:=$(ARCH)-linux-
endif