summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorUlf Samuelsson2007-08-14 09:45:01 +0200
committerUlf Samuelsson2007-08-14 09:45:01 +0200
commitf958d89724e5db98943e28c2dda45a86f27e6401 (patch)
tree063c1812c12079c9b79405cf8fc078768f7debf8 /Makefile
parentAvoid continuous rebuilds of TARGET_DIR and /etc/* project files (diff)
downloadbuildroot-f958d89724e5db98943e28c2dda45a86f27e6401.tar.gz
buildroot-f958d89724e5db98943e28c2dda45a86f27e6401.tar.xz
buildroot-f958d89724e5db98943e28c2dda45a86f27e6401.zip
Move project related info from main Makefile to project dir
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 6 insertions, 20 deletions
diff --git a/Makefile b/Makefile
index 4d5227ba6..89e6caef1 100644
--- a/Makefile
+++ b/Makefile
@@ -162,14 +162,7 @@ BASE_TARGETS:=uclibc
endif
TARGETS:=
-
-PROJECT:=$(strip $(subst ",,$(BR2_PROJECT)))
-#"))
-TARGET_HOSTNAME:=$(strip $(subst ",,$(BR2_HOSTNAME)))
-#"))
-BANNER:=$(strip $(subst ",,$(BR2_BANNER)))
-#"))
-
+include project/Makefile.in
include toolchain/Makefile.in
include package/Makefile.in
@@ -185,6 +178,8 @@ all: world
# In this section, we need .config
include .config.cmd
+include project/*.mk
+
# We also need the various per-package makefiles, which also add
# each selected package to TARGETS if that package was selected
# in the .config file.
@@ -213,11 +208,13 @@ $(TARGETS): $(BASE_TARGETS)
dirs: $(DL_DIR) $(TOOL_BUILD_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(BINARIES_DIR) $(PROJECT_BUILD_DIR)
+
$(BASE_TARGETS): dirs
+
world: dependencies dirs target-host-info $(BASE_TARGETS) $(TARGETS)
-.PHONY: all world dirs clean dirclean distclean source target-host-info \
+.PHONY: all world dirs clean dirclean distclean source \
$(BASE_TARGETS) $(TARGETS) \
$(TARGETS_CLEAN) $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) \
$(DL_DIR) $(TOOL_BUILD_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
@@ -258,17 +255,6 @@ $(PROJECT_BUILD_DIR)/.root: $(TARGET_DIR)
fi;
touch $@
-target-host-info: $(TARGET_DIR)/etc/issue $(TARGET_DIR)/etc/hostname
-
-$(TARGET_DIR)/etc/issue: .config
- mkdir -p $(TARGET_DIR)/etc
- echo "" > $(TARGET_DIR)/etc/issue
- echo "" >> $(TARGET_DIR)/etc/issue
- echo "$(BANNER)" >> $(TARGET_DIR)/etc/issue
-
-$(TARGET_DIR)/etc/hostname: .config
- mkdir -p $(TARGET_DIR)/etc
- echo "$(TARGET_HOSTNAME)" > $(TARGET_DIR)/etc/hostname
source: $(TARGETS_SOURCE) $(HOST_SOURCE)