summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2009-07-31 10:26:28 +0200
committerThomas Petazzoni2009-09-16 20:33:27 +0200
commitfd3800c1979d9d76e2c4f802c2d279290c102218 (patch)
treef87c944a7141d6c5e2e9e96b5b14399858de2ee9 /Makefile
parentBy default, put the output in an output/ directory (diff)
downloadbuildroot-fd3800c1979d9d76e2c4f802c2d279290c102218.tar.gz
buildroot-fd3800c1979d9d76e2c4f802c2d279290c102218.tar.xz
buildroot-fd3800c1979d9d76e2c4f802c2d279290c102218.zip
Remove BR2_TOPDIR_PREFIX and BR2_TOPDIR_SUFFIX
The same effect can be done using out-of-tree build with O= Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 8b07786bb..d49320046 100644
--- a/Makefile
+++ b/Makefile
@@ -230,21 +230,12 @@ endif
BASE_DIR := $(shell mkdir -p $(O) && cd $(O) && pwd)
$(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))
-TOPDIR_PREFIX:=$(call qstrip,$(BR2_TOPDIR_PREFIX))_
-TOPDIR_SUFFIX:=_$(call qstrip,$(BR2_TOPDIR_SUFFIX))
-ifeq ($(TOPDIR_PREFIX),_)
-TOPDIR_PREFIX:=
-endif
-ifeq ($(TOPDIR_SUFFIX),_)
-TOPDIR_SUFFIX:=
-endif
-
DL_DIR=$(call qstrip,$(BR2_DL_DIR))
ifeq ($(DL_DIR),)
DL_DIR:=$(BASE_DIR)/dl
endif
-BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
+BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
GNU_TARGET_SUFFIX:=-$(call qstrip,$(BR2_GNU_TARGET_SUFFIX))