summaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorThomas Petazzoni2011-11-13 09:54:47 +0100
committerPeter Korsgaard2011-11-13 21:30:33 +0100
commite17418480719803f4454c4393c5be5d2c0f8033a (patch)
tree4b068f940d91b2bf59a3ba0bea0ba092b58733c7 /docs
parentdoc: mention the CMAKETARGETS infrastructure in the list of infrastructures (diff)
downloadbuildroot-e17418480719803f4454c4393c5be5d2c0f8033a.tar.gz
buildroot-e17418480719803f4454c4393c5be5d2c0f8033a.tar.xz
buildroot-e17418480719803f4454c4393c5be5d2c0f8033a.zip
doc: update GENTARGETS/AUTOTARGETS/CMAKETARGETS on the number of arguments
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/adding-packages-autotargets.txt2
-rw-r--r--docs/manual/adding-packages-cmaketargets.txt2
-rw-r--r--docs/manual/adding-packages-gentargets.txt29
3 files changed, 10 insertions, 23 deletions
diff --git a/docs/manual/adding-packages-autotargets.txt b/docs/manual/adding-packages-autotargets.txt
index cb41eadfd..428a1822b 100644
--- a/docs/manual/adding-packages-autotargets.txt
+++ b/docs/manual/adding-packages-autotargets.txt
@@ -23,7 +23,7 @@ package, with an example :
11: LIBFOO_CONF_OPT = --enable-shared
12: LIBFOO_DEPENDENCIES = libglib2 host-pkg-config
13:
-14: $(eval $(call AUTOTARGETS,package,libfoo))
+14: $(eval $(call AUTOTARGETS))
------------------------
On line 6, we declare the version of the package.
diff --git a/docs/manual/adding-packages-cmaketargets.txt b/docs/manual/adding-packages-cmaketargets.txt
index b03eb6894..3e400ec14 100644
--- a/docs/manual/adding-packages-cmaketargets.txt
+++ b/docs/manual/adding-packages-cmaketargets.txt
@@ -23,7 +23,7 @@ with an example :
11: LIBFOO_CONF_OPT = -DBUILD_DEMOS=ON
12: LIBFOO_DEPENDENCIES = libglib2 host-pkg-config
13:
-14: $(eval $(call CMAKETARGETS,package,libfoo))
+14: $(eval $(call CMAKETARGETS))
------------------------
On line 6, we declare the version of the package.
diff --git a/docs/manual/adding-packages-gentargets.txt b/docs/manual/adding-packages-gentargets.txt
index 9a319d161..29fc64028 100644
--- a/docs/manual/adding-packages-gentargets.txt
+++ b/docs/manual/adding-packages-gentargets.txt
@@ -38,7 +38,7 @@ system is based on hand-written Makefiles or shell scripts.
24: $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/foo.d
25: endef
26:
-27: $(eval $(call GENTARGETS,package,libfoo))
+27: $(eval $(call GENTARGETS))
--------------------------------
The Makefile begins on line 6 to 8 with metadata information: the
@@ -84,32 +84,19 @@ Makefile code necessary to make your package working.
+GENTARGETS+ Reference
~~~~~~~~~~~~~~~~~~~~~~
-The +GENTARGETS+ macro takes three arguments:
-
-* The first argument is the package directory prefix. If your package
- is in +package/libfoo+, then the directory prefix is +package+. If
- your package is in +package/editors/foo+, then the directory prefix
- must be +package/editors+.
-
-* The second argument is the lower-cased package name. It must match
- the prefix of the variables in the +.mk+ file and must match the
- configuration option name in the +Config.in+ file. For example, if
- the package name is +libfoo+, then the variables in the +.mk+ file
- must start with +LIBFOO_+ and the configuration option in the
- +Config.in+ file must be +BR2_PACKAGE_LIBFOO+.
-
-* The third argument is optional. It can be used to tell if the
- package is a target package (cross-compiled for the target) or a
- host package (natively compiled for the host). If unspecified, it is
- assumed that it is a target package. See below for details.
+The +GENTARGETS+ macro takes one optional argument. This argument can
+be used to tell if the package is a target package (cross-compiled for
+the target) or a host package (natively compiled for the host). If
+unspecified, it is assumed that it is a target package. See below for
+details.
For a given package, in a single +.mk+ file, it is possible to call
GENTARGETS twice, once to create the rules to generate a target
package and once to create the rules to generate a host package:
----------------------
-$(eval $(call GENTARGETS,package,libfoo))
-$(eval $(call GENTARGETS,package,libfoo,host))
+$(eval $(call GENTARGETS))
+$(eval $(call GENTARGETS,host))
----------------------
This might be useful if the compilation of the target package requires