summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni2011-09-29 21:57:42 +0200
committerPeter Korsgaard2011-09-29 23:09:58 +0200
commit0849e8193ef429f29945b8c2a54eafc8635e0969 (patch)
tree87934d420647a042d53c0332e15d4d02404b8010 /linux
parentpackage: add helper functions to get package name and directory magically (diff)
downloadbuildroot-0849e8193ef429f29945b8c2a54eafc8635e0969.tar.gz
buildroot-0849e8193ef429f29945b8c2a54eafc8635e0969.tar.xz
buildroot-0849e8193ef429f29945b8c2a54eafc8635e0969.zip
package: remove useless arguments from GENTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the GENTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 600b14d75..99f464966 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -179,7 +179,7 @@ endef
include linux/linux-ext-*.mk
-$(eval $(call GENTARGETS,,linux))
+$(eval $(call GENTARGETS))
linux-menuconfig linux-xconfig linux-gconfig linux-nconfig linux26-menuconfig linux26-xconfig linux26-gconfig linux26-nconfig: dirs $(LINUX_DIR)/.stamp_configured
$(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) \