summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorGustavo Zacarias2012-05-05 05:30:23 +0200
committerPeter Korsgaard2012-05-05 16:21:40 +0200
commit5308d111b72bdce228252ebe2e44e28484117c5f (patch)
tree4724a05db45449f470ce08e28c19fee403e75a2f /linux
parentlinux: improve the 'make linux-*' special commands (diff)
downloadbuildroot-5308d111b72bdce228252ebe2e44e28484117c5f.tar.gz
buildroot-5308d111b72bdce228252ebe2e44e28484117c5f.tar.xz
buildroot-5308d111b72bdce228252ebe2e44e28484117c5f.zip
ocf-linux: new package
Add the ocf-linux package and linux kernel extension. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.ext.in12
-rw-r--r--linux/linux-ext-ocf-linux.mk23
2 files changed, 35 insertions, 0 deletions
diff --git a/linux/Config.ext.in b/linux/Config.ext.in
index 172fa76c7..a68cbe921 100644
--- a/linux/Config.ext.in
+++ b/linux/Config.ext.in
@@ -23,6 +23,18 @@ config BR2_LINUX_KERNEL_EXT_XENOMAI_ADEOS_PATCH
Download it at http://download.gna.org/adeos/patches/v2.6/$(ARCH)/
and verify that your kernel version in buildroot matches.
+# ocf-linux
+config BR2_LINUX_KERNEL_EXT_OCF_LINUX
+ bool "Open Cryptographic Framework (OCF)"
+ select BR2_PACKAGE_OCF_LINUX
+ help
+ OCF-Linux Kernel part.
+
+ Select this option to patch your kernel with OCF for
+ hardware-accelerated crypto support for available drivers.
+ Some libraries need to also have OCF enabled for them,
+ for example OpenSSL.
+
# RTAI
config BR2_LINUX_KERNEL_EXT_RTAI
bool "RTAI Real-time patch"
diff --git a/linux/linux-ext-ocf-linux.mk b/linux/linux-ext-ocf-linux.mk
new file mode 100644
index 000000000..faf7360e4
--- /dev/null
+++ b/linux/linux-ext-ocf-linux.mk
@@ -0,0 +1,23 @@
+##################################################
+# Linux OCF extension
+#
+# Patch the linux kernel with OCF
+##################################################
+
+ifeq ($(BR2_LINUX_KERNEL_EXT_OCF_LINUX),y)
+LINUX_DEPENDENCIES += ocf-linux
+
+# Prepare kernel patch
+# The linux-3.2.1.patch is just the main inclusion, most of the code
+# resides in the ocf/ subdir.
+# It works for older kernel versions.
+# Run tested from 2.6.38+ and build tested from 2.6.35+
+define OCF_LINUX_PREPARE_KERNEL
+ support/scripts/apply-patches.sh $(LINUX_DIR) \
+ $(OCF_LINUX_DIR)/patches/ linux-3.2.1-ocf.patch ; \
+ cp -rf $(OCF_LINUX_DIR)/ocf $(LINUX_DIR)/crypto/ocf ;
+endef
+
+LINUX_PRE_PATCH_HOOKS += OCF_LINUX_PREPARE_KERNEL
+
+endif #BR2_LINUX_EXT_OCF_LINUX