summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni2012-01-31 20:39:59 +0100
committerPeter Korsgaard2012-01-31 23:23:11 +0100
commit5ba5301cdc9e7c7d4348f7bfdf567592fcc7882f (patch)
treeb91d16b026fcba5b0c1aa2c6f396e7896b5559cc /linux
parentgst-dsp: bump version (diff)
downloadbuildroot-5ba5301cdc9e7c7d4348f7bfdf567592fcc7882f.tar.gz
buildroot-5ba5301cdc9e7c7d4348f7bfdf567592fcc7882f.tar.xz
buildroot-5ba5301cdc9e7c7d4348f7bfdf567592fcc7882f.zip
linux: use the depmod built in HOST_DIR
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 5c5a1d296..dbe1ad78c 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -40,7 +40,8 @@ LINUX_MAKE_FLAGS = \
ARCH=$(KERNEL_ARCH) \
INSTALL_MOD_PATH=$(TARGET_DIR) \
CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
- LZMA="$(LZMA)"
+ LZMA="$(LZMA)" \
+ DEPMOD=$(HOST_DIR)/usr/sbin/depmod
# Get the real Linux version, which tells us where kernel modules are
# going to be installed in the target filesystem.