summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorThomas De Schampheleire2012-05-15 10:18:25 +0200
committerPeter Korsgaard2012-05-15 22:59:20 +0200
commit707d44d0a28906ebda49584dd5f55985406f0bde (patch)
tree03353bdfdfba3374670fe7f54ad79c9e5a0f3776 /linux
parentrtorrent: new package (diff)
downloadbuildroot-707d44d0a28906ebda49584dd5f55985406f0bde.tar.gz
buildroot-707d44d0a28906ebda49584dd5f55985406f0bde.tar.xz
buildroot-707d44d0a28906ebda49584dd5f55985406f0bde.zip
linux: install dtc (device tree compiler) as host tool if selected
Having dtc as a host tool can be useful for users that have a custom boot scenario where the device tree is not embedded in the kernel. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 34f86236c..f165dda50 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -183,6 +183,15 @@ define LINUX_INSTALL_KERNEL_IMAGE_TO_TARGET
endef
endif
+
+define LINUX_INSTALL_HOST_TOOLS
+ # Installing dtc (device tree compiler) as host tool, if selected
+ if grep -q "CONFIG_DTC=y" $(@D)/.config; then \
+ $(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/usr/bin/dtc ; \
+ fi
+endef
+
+
define LINUX_INSTALL_IMAGES_CMDS
cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
endef
@@ -197,6 +206,7 @@ define LINUX_INSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/lib/modules/$(LINUX_VERSION_PROBED)/build ; \
rm -f $(TARGET_DIR)/lib/modules/$(LINUX_VERSION_PROBED)/source ; \
fi
+ $(LINUX_INSTALL_HOST_TOOLS)
endef
include linux/linux-ext-*.mk