summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorMaxime Ripard2012-03-23 16:49:53 +0100
committerPeter Korsgaard2012-04-02 23:14:04 +0200
commit90759a663629d3c936c0e4392088a4e618aaf5fe (patch)
tree2644b7d79ea891deed4643c441ba39c2945e4659 /linux
parentlibpng: bump to version 1.4.10 (diff)
downloadbuildroot-90759a663629d3c936c0e4392088a4e618aaf5fe.tar.gz
buildroot-90759a663629d3c936c0e4392088a4e618aaf5fe.tar.xz
buildroot-90759a663629d3c936c0e4392088a4e618aaf5fe.zip
Enable cgroups in Linux if we use systemd
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 6cb1efc86..16f99163d 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -162,6 +162,8 @@ define LINUX_CONFIGURE_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config))
$(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),
$(call KCONFIG_SET_OPT,CONFIG_UEVENT_HELPER_PATH,\"/sbin/mdev\",$(@D)/.config))
+ $(if $(BR2_PACKAGE_SYSTEMD),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_CGROUPS,$(@D)/.config))
yes '' | $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) oldconfig
endef