summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard2012-05-31 09:23:23 +0200
committerPeter Korsgaard2012-05-31 09:23:23 +0200
commitbdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2 (patch)
treed6012109e704c5e9abc709c23a7133a3d4b4f779 /linux
parentKickoff 2012.08 cycle (diff)
parentnfs-utils: bump to version 1.2.6 (diff)
downloadbuildroot-bdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2.tar.gz
buildroot-bdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2.tar.xz
buildroot-bdb4c3a6dc9efecc4d1e40fabf8cb9b3e0eb3ee2.zip
Merge branch 'next'
Conflicts: toolchain/kernel-headers/Config.in
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 34f86236c..f165dda50 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -183,6 +183,15 @@ define LINUX_INSTALL_KERNEL_IMAGE_TO_TARGET
endef
endif
+
+define LINUX_INSTALL_HOST_TOOLS
+ # Installing dtc (device tree compiler) as host tool, if selected
+ if grep -q "CONFIG_DTC=y" $(@D)/.config; then \
+ $(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/usr/bin/dtc ; \
+ fi
+endef
+
+
define LINUX_INSTALL_IMAGES_CMDS
cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
endef
@@ -197,6 +206,7 @@ define LINUX_INSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/lib/modules/$(LINUX_VERSION_PROBED)/build ; \
rm -f $(TARGET_DIR)/lib/modules/$(LINUX_VERSION_PROBED)/source ; \
fi
+ $(LINUX_INSTALL_HOST_TOOLS)
endef
include linux/linux-ext-*.mk