summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni2011-09-19 22:10:53 +0200
committerPeter Korsgaard2011-09-20 22:18:16 +0200
commitbe27a7933f12af29346eb7e73e0a0ca9ae7f947d (patch)
treef9df4bfc8f13570d2c7695a2ac74e69251195748 /linux
parentpackage: add a PRE_PATCH_HOOKS hook point (diff)
downloadbuildroot-be27a7933f12af29346eb7e73e0a0ca9ae7f947d.tar.gz
buildroot-be27a7933f12af29346eb7e73e0a0ca9ae7f947d.tar.xz
buildroot-be27a7933f12af29346eb7e73e0a0ca9ae7f947d.zip
rtai, xenomai: use the pre patch hook point
The post extract hook point is not really correct as what RTAI and Xenomai extensions are doing is patching the kernel. The post patch hook point doesn't work, because RTAI and Xenomai patches would be applied *after* all other patches, while it sounds more logical to apply them first, and *then* allow the user to apply some platform/board specific patches if needed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux-ext-rtai.mk2
-rw-r--r--linux/linux-ext-xenomai.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/linux/linux-ext-rtai.mk b/linux/linux-ext-rtai.mk
index a54230d32..150f9e897 100644
--- a/linux/linux-ext-rtai.mk
+++ b/linux/linux-ext-rtai.mk
@@ -42,6 +42,6 @@ define RTAI_PREPARE_KERNEL
endef
endif
-LINUX_POST_PATCH_HOOKS += RTAI_PREPARE_KERNEL
+LINUX_PRE_PATCH_HOOKS += RTAI_PREPARE_KERNEL
endif #BR2_LINUX_EXT_RTAI
diff --git a/linux/linux-ext-xenomai.mk b/linux/linux-ext-xenomai.mk
index e855deddf..9b6772e23 100644
--- a/linux/linux-ext-xenomai.mk
+++ b/linux/linux-ext-xenomai.mk
@@ -25,6 +25,6 @@ define XENOMAI_PREPARE_KERNEL
--verbose
endef
-LINUX_POST_EXTRACT_HOOKS += XENOMAI_PREPARE_KERNEL
+LINUX_PRE_PATCH_HOOKS += XENOMAI_PREPARE_KERNEL
endif #BR2_LINUX_EXT_XENOMAI