summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorMarkus Kaindl2012-03-21 02:19:04 +0100
committerPeter Korsgaard2012-03-21 11:44:22 +0100
commitc9ccdf877a6a5af54ac8b6d2809361ed1ddcc221 (patch)
tree6311d62fd0078f6e41d9875dd88c8fec29d64b3b /linux
parentlibupnp: bump to version 1.6.15 (diff)
downloadbuildroot-c9ccdf877a6a5af54ac8b6d2809361ed1ddcc221.tar.gz
buildroot-c9ccdf877a6a5af54ac8b6d2809361ed1ddcc221.tar.xz
buildroot-c9ccdf877a6a5af54ac8b6d2809361ed1ddcc221.zip
linux.mk: .ub-File copying after building initramfs
test should exit with Exit-Code 0 if no .ub-File present and copy the file if Exit-Code 1, otherwise make fails Signed-off-by: Markus Kaindl <markus.kaindl@stusta.mhn.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index c0334d2b7..6cb1efc86 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -230,7 +230,7 @@ $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
# Copy the kernel image to its final destination
cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
# If there is a .ub file copy it to the final destination
- test -f $(LINUX_IMAGE_PATH).ub && cp $(LINUX_IMAGE_PATH).ub $(BINARIES_DIR)
+ test ! -f $(LINUX_IMAGE_PATH).ub || cp $(LINUX_IMAGE_PATH).ub $(BINARIES_DIR)
$(Q)touch $@
# The initramfs building code must make sure this target gets called