summaryrefslogtreecommitdiffstats
path: root/make/bash.mk
diff options
context:
space:
mode:
authorEric Andersen2002-10-23 14:54:42 +0200
committerEric Andersen2002-10-23 14:54:42 +0200
commit77bf6fb0e642c004c28698f651bd4dc2939157f3 (patch)
tree14a016172973704d690801d2cc86be81685c25d9 /make/bash.mk
parentUpdate things to be a tad more current (diff)
downloadbuildroot-77bf6fb0e642c004c28698f651bd4dc2939157f3.tar.gz
buildroot-77bf6fb0e642c004c28698f651bd4dc2939157f3.tar.xz
buildroot-77bf6fb0e642c004c28698f651bd4dc2939157f3.zip
Add several new components working towards a fully sandboxed buildsystem
-Erik
Diffstat (limited to 'make/bash.mk')
-rw-r--r--make/bash.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/make/bash.mk b/make/bash.mk
new file mode 100644
index 000000000..869be9df0
--- /dev/null
+++ b/make/bash.mk
@@ -0,0 +1,45 @@
+#############################################################
+#
+# bash
+#
+#############################################################
+BASH_SOURCE:=bash-2.05b.tar.gz
+BASH_SITE:=ftp://ftp.gnu.org/gnu/bash
+BASH_CAT:=zcat
+BASH_DIR:=$(BUILD_DIR)/bash-2.05b
+BASH_BINARY:=bash
+BASH_TARGET_BINARY:=bin/bash
+
+$(DL_DIR)/$(BASH_SOURCE):
+ wget -P $(DL_DIR) $(BASH_SITE)/$(BASH_SOURCE)
+
+bash-source: $(DL_DIR)/$(BASH_SOURCE)
+
+$(BASH_DIR)/.unpacked: $(DL_DIR)/$(BASH_SOURCE)
+ $(BASH_CAT) $(DL_DIR)/$(BASH_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch $(BASH_DIR)/.unpacked
+
+$(BASH_DIR)/.configured: $(BASH_DIR)/.unpacked
+ (cd $(BASH_DIR); autoconf; rm -f config.cache; CC=$(TARGET_CC1) \
+ CFLAGS=-D_POSIX_SOURCE ./configure --prefix=/usr --disable-nls \
+ --mandir=/junk --infodir=/junk \
+ );
+ touch $(BASH_DIR)/.configured
+
+$(BASH_DIR)/$(BASH_BINARY): $(BASH_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC1) -C $(BASH_DIR)
+
+$(TARGET_DIR)/$(BASH_TARGET_BINARY): $(BASH_DIR)/$(BASH_BINARY)
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(BASH_DIR) install
+ mv $(TARGET_DIR)/usr/bin/bash* $(TARGET_DIR)/bin/
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/junk
+
+bash: ncurses uclibc $(TARGET_DIR)/$(BASH_TARGET_BINARY)
+
+bash-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(BASH_DIR) uninstall
+ -make -C $(BASH_DIR) clean
+
+bash-dirclean:
+ rm -rf $(BASH_DIR)
+