summaryrefslogtreecommitdiffstats
path: root/make/binutils-uclibc.mk
diff options
context:
space:
mode:
authorManuel Novoa III2004-03-01 07:28:02 +0100
committerManuel Novoa III2004-03-01 07:28:02 +0100
commit93703bf40fa3797317ea73018101e53e85397a9b (patch)
treedcc7c7ffd7b9a21dc2d6304958ddfdf432d280d0 /make/binutils-uclibc.mk
parentDisable autologin (diff)
downloadbuildroot-93703bf40fa3797317ea73018101e53e85397a9b.tar.gz
buildroot-93703bf40fa3797317ea73018101e53e85397a9b.tar.xz
buildroot-93703bf40fa3797317ea73018101e53e85397a9b.zip
Revert back to binutils .6 since .8 broke things on arm.
Also, explicitly set the CFLAGS for the build system since otherwise the TARGET_OPTIMIZATION flags were used. This was tripping up a mipsel build where it tried to use -mips2 when building for i386.
Diffstat (limited to 'make/binutils-uclibc.mk')
-rw-r--r--make/binutils-uclibc.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/make/binutils-uclibc.mk b/make/binutils-uclibc.mk
index 955f5db2e..0f3296497 100644
--- a/make/binutils-uclibc.mk
+++ b/make/binutils-uclibc.mk
@@ -4,8 +4,8 @@
#
#############################################################
BINUTILS_SITE:=http://ftp.kernel.org/pub/linux/devel/binutils
-BINUTILS_SOURCE:=binutils-2.14.90.0.8.tar.bz2
-BINUTILS_DIR:=$(TOOL_BUILD_DIR)/binutils-2.14.90.0.8
+BINUTILS_SOURCE:=binutils-2.14.90.0.6.tar.bz2
+BINUTILS_DIR:=$(TOOL_BUILD_DIR)/binutils-2.14.90.0.6
BINUTILS_CAT:=bzcat
BINUTILS_DIR1:=$(TOOL_BUILD_DIR)/binutils-build
@@ -83,6 +83,7 @@ $(BINUTILS_DIR2)/.configured: $(BINUTILS_DIR)/.patched
(cd $(BINUTILS_DIR2); \
PATH=$(TARGET_PATH) \
CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS_FOR_BUILD="-O2 -g" \
$(BINUTILS_DIR)/configure \
--prefix=/usr \
--exec-prefix=/usr \