summaryrefslogtreecommitdiffstats
path: root/make/bison.mk
diff options
context:
space:
mode:
authorEric Andersen2003-02-12 11:40:28 +0100
committerEric Andersen2003-02-12 11:40:28 +0100
commit089db85919e922846426e9942fae37ccc146739f (patch)
tree661c6e0eba866b08950ab557052ebb5b9c64b745 /make/bison.mk
parentUpdate toolchains a bit forther so that after blowing away the 'build' (diff)
downloadbuildroot-089db85919e922846426e9942fae37ccc146739f.tar.gz
buildroot-089db85919e922846426e9942fae37ccc146739f.tar.xz
buildroot-089db85919e922846426e9942fae37ccc146739f.zip
Add support for several new utilities
Diffstat (limited to 'make/bison.mk')
-rw-r--r--make/bison.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/make/bison.mk b/make/bison.mk
new file mode 100644
index 000000000..512e1eb7b
--- /dev/null
+++ b/make/bison.mk
@@ -0,0 +1,58 @@
+#############################################################
+#
+# bison
+#
+#############################################################
+BISON_SOURCE:=bison-1.75.tar.bz2
+BISON_SITE:=ftp://ftp.gnu.org/gnu/bison
+BISON_DIR:=$(BUILD_DIR)/bison-1.75
+BISON_CAT:=bzcat
+BISON_BINARY:=src/bison
+BISON_TARGET_BINARY:=usr/bin/bison
+
+$(DL_DIR)/$(BISON_SOURCE):
+ $(WGET) -P $(DL_DIR) $(BISON_SITE)/$(BISON_SOURCE)
+
+bison-source: $(DL_DIR)/$(BISON_SOURCE)
+
+$(BISON_DIR)/.unpacked: $(DL_DIR)/$(BISON_SOURCE)
+ $(BISON_CAT) $(DL_DIR)/$(BISON_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch $(BISON_DIR)/.unpacked
+
+$(BISON_DIR)/.configured: $(BISON_DIR)/.unpacked
+ (cd $(BISON_DIR); rm -rf config.cache; \
+ PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-nls \
+ );
+ touch $(BISON_DIR)/.configured
+
+$(BISON_DIR)/$(BISON_BINARY): $(BISON_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC) -C $(BISON_DIR)
+
+$(TARGET_DIR)/$(BISON_TARGET_BINARY): $(BISON_DIR)/$(BISON_BINARY)
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) install
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+ (cd $(TARGET_DIR)/usr/bin; ln -s bison yacc)
+
+bison: uclibc $(TARGET_DIR)/$(BISON_TARGET_BINARY)
+
+bison-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) uninstall
+ -$(MAKE) -C $(BISON_DIR) clean
+
+bison-dirclean:
+ rm -rf $(BISON_DIR)
+