summaryrefslogtreecommitdiffstats
path: root/make/gawk.mk
diff options
context:
space:
mode:
authorEric Andersen2003-01-07 22:00:41 +0100
committerEric Andersen2003-01-07 22:00:41 +0100
commit3a70952d991368609d9bd7e3b4532a3434a091de (patch)
tree057f1baae5acf20fe15ce00639784d70a000e65e /make/gawk.mk
parentShuffle so binutils is unpacked/built first (diff)
downloadbuildroot-3a70952d991368609d9bd7e3b4532a3434a091de.tar.gz
buildroot-3a70952d991368609d9bd7e3b4532a3434a091de.tar.xz
buildroot-3a70952d991368609d9bd7e3b4532a3434a091de.zip
more build updates
Diffstat (limited to 'make/gawk.mk')
-rw-r--r--make/gawk.mk18
1 files changed, 16 insertions, 2 deletions
diff --git a/make/gawk.mk b/make/gawk.mk
index 0994ef80d..84671a6fe 100644
--- a/make/gawk.mk
+++ b/make/gawk.mk
@@ -21,8 +21,22 @@ $(GAWK_DIR)/.unpacked: $(DL_DIR)/$(GAWK_SOURCE)
$(GAWK_DIR)/.configured: $(GAWK_DIR)/.unpacked
(cd $(GAWK_DIR); rm -f config.cache; CC=$(TARGET_CC1) \
- CFLAGS=-D_POSIX_SOURCE ./configure --prefix=/usr --disable-nls \
- --mandir=/junk --infodir=/junk \
+ CFLAGS=-D_POSIX_SOURCE ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --datadir=/usr/share \
+ --libdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/junk \
+ --infodir=/junk \
+ --includedir=$(STAGING_DIR)/include \
+ --oldincludedir=$(STAGING_DIR)/usr/include \
+ --disable-nls \
);
touch $(GAWK_DIR)/.configured