summaryrefslogtreecommitdiffstats
path: root/make/gdb.mk
diff options
context:
space:
mode:
authorManuel Novoa III2003-09-03 09:18:18 +0200
committerManuel Novoa III2003-09-03 09:18:18 +0200
commit0e956fc164b97347279045e60033e6f2f176df3b (patch)
treebe9515a9bae85c641ce8c8756d378eb367614c4c /make/gdb.mk
parentFixup binutils cross builds (diff)
downloadbuildroot-0e956fc164b97347279045e60033e6f2f176df3b.tar.gz
buildroot-0e956fc164b97347279045e60033e6f2f176df3b.tar.xz
buildroot-0e956fc164b97347279045e60033e6f2f176df3b.zip
Add support for enabling use of libintl.
Add support for libstd++ in full locale mode, and remove the need for config hacks when using uClibc stub locale support. TODO -- gdb intl support is still broken. uClibc should auto-download the pregenerated locale data
Diffstat (limited to 'make/gdb.mk')
-rw-r--r--make/gdb.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/make/gdb.mk b/make/gdb.mk
index e696b65ec..7bff3399f 100644
--- a/make/gdb.mk
+++ b/make/gdb.mk
@@ -15,11 +15,15 @@ $(DL_DIR)/$(GDB_SOURCE):
$(GDB_DIR)/.unpacked: $(DL_DIR)/$(GDB_SOURCE) $(GDB_PATCH)
gunzip -c $(DL_DIR)/$(GDB_SOURCE) | tar -C $(BUILD_DIR) -xvf -
cat $(GDB_PATCH) | patch -p1 -d $(GDB_DIR)
+ #-perl -i -p -e "s,\@INTLLIBS\@,-lintl,g;" $(GDB_DIR)/gdb/Makefile.in
touch $(GDB_DIR)/.unpacked
$(GDB_DIR)/.configured: $(GDB_DIR)/.unpacked
(cd $(GDB_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
+ ac_cv_type_uintptr_t=yes \
+ gt_cv_func_gettext_libintl=yes \
+ ac_cv_func_dcgettext=yes \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -34,7 +38,7 @@ $(GDB_DIR)/.configured: $(GDB_DIR)/.unpacked
--mandir=/usr/man \
--infodir=/usr/info \
--includedir=$(STAGING_DIR)/include \
- --disable-nls \
+ $(DISABLE_NLS) \
--without-uiout --disable-gdbmi \
--disable-tui --disable-gdbtk --without-x \
--disable-sim --enable-gdbserver \