summaryrefslogtreecommitdiffstats
path: root/make/gdb.mk
diff options
context:
space:
mode:
authorEric Andersen2003-01-17 09:03:59 +0100
committerEric Andersen2003-01-17 09:03:59 +0100
commitef7784a62d2ecd681b37aee7040e71bbb34a51cd (patch)
tree92daacce553b174393de87921912ada04a4ecb6e /make/gdb.mk
parentbe sure include dir is present (diff)
downloadbuildroot-ef7784a62d2ecd681b37aee7040e71bbb34a51cd.tar.gz
buildroot-ef7784a62d2ecd681b37aee7040e71bbb34a51cd.tar.xz
buildroot-ef7784a62d2ecd681b37aee7040e71bbb34a51cd.zip
standardize handling of GNU configure scripts
-Erik
Diffstat (limited to 'make/gdb.mk')
-rw-r--r--make/gdb.mk33
1 files changed, 22 insertions, 11 deletions
diff --git a/make/gdb.mk b/make/gdb.mk
index 04663e511..51eff8bc5 100644
--- a/make/gdb.mk
+++ b/make/gdb.mk
@@ -16,19 +16,30 @@ $(GDB_DIR)/.unpacked: $(DL_DIR)/$(GDB_SOURCE)
touch $(GDB_DIR)/.unpacked
$(GDB_DIR)/.configured: $(GDB_DIR)/.unpacked
- (cd $(GDB_DIR); rm -rf config.cache; CC=$(TARGET_CC1) \
- AR=$(TARGET_CROSS)ar NM=$(TARGET_CROSS)nm \
- LD=$(TARGET_CROSS)ld AS=$(TARGET_CROSS)as \
- ./configure --prefix=/usr \
- --includedir=$(STAGING_DIR)/include \
- --disable-nls --without-uiout --disable-gdbmi \
- --disable-tui --disable-gdbtk --without-x \
- --disable-sim --enable-gdbserver \
- --without-included-gettext);
+ (cd $(GDB_DIR); rm -rf config.cache; \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-nls \
+ --without-uiout --disable-gdbmi \
+ --disable-tui --disable-gdbtk --without-x \
+ --disable-sim --enable-gdbserver \
+ --without-included-gettext \
+ );
touch $(GDB_DIR)/.configured
$(GDB_DIR)/gdb/gdb: $(GDB_DIR)/.configured
- make CC=$(TARGET_CC1) -C $(GDB_DIR)
+ $(MAKE) CC=$(TARGET_CC1) -C $(GDB_DIR)
$(STRIP) $(GDB_DIR)/gdb/gdb
$(TARGET_DIR)/usr/bin/gdb: $(GDB_DIR)/gdb/gdb
@@ -37,7 +48,7 @@ $(TARGET_DIR)/usr/bin/gdb: $(GDB_DIR)/gdb/gdb
gdb: $(TARGET_DIR)/usr/bin/gdb
gdb-clean:
- make -C $(GDB_DIR) clean
+ $(MAKE) -C $(GDB_DIR) clean
gdb-dirclean:
rm -rf $(GDB_DIR)