summaryrefslogtreecommitdiffstats
path: root/make/kernel-headers.mk
diff options
context:
space:
mode:
authorEric Andersen2003-11-12 10:31:12 +0100
committerEric Andersen2003-11-12 10:31:12 +0100
commit0fee9e90c2ea3accfaa521a303c6568ebf7baccc (patch)
tree2d18515f482954fb771dc19671c9056511f71127 /make/kernel-headers.mk
parentKill off --with-lib-path, since --with-sysroot is sufficient, (diff)
downloadbuildroot-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.tar.gz
buildroot-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.tar.xz
buildroot-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.zip
Thomas Cameron writes:
this patch fixes the source file downloads when executing a "make source", and a few cut-and-paste (tm) errors in the *.mk files. Again, this is a patch against the current CVS sources, and includes my previous patch.
Diffstat (limited to 'make/kernel-headers.mk')
-rw-r--r--make/kernel-headers.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/make/kernel-headers.mk b/make/kernel-headers.mk
index 1c9483ba5..183823e47 100644
--- a/make/kernel-headers.mk
+++ b/make/kernel-headers.mk
@@ -50,13 +50,15 @@ $(LINUX_DIR)/.configured: $(LINUX_DIR)/.unpacked
$(LINUX_KERNEL): $(LINUX_DIR)/.configured
-system-linux: $(LINUX_DIR)/.configured
+kernel-headers: $(LINUX_DIR)/.configured
-system-linux-clean: clean
+kernel-headers-source: $(DL_DIR)/$(LINUX_SOURCE)
+
+kernel-headers-clean: clean
rm -f $(LINUX_KERNEL)
rm -rf $(LINUX_DIR)
-system-linux-dirclean:
+kernel-headers-dirclean:
rm -rf $(LINUX_DIR)
endif