summaryrefslogtreecommitdiffstats
path: root/make/netkittelnet.mk
diff options
context:
space:
mode:
authorEric Andersen2003-11-19 18:17:56 +0100
committerEric Andersen2003-11-19 18:17:56 +0100
commit4f889ada561fbdffeefa1a8327d5b8939b021685 (patch)
tree925b247ee7718930f470b2c1843cb15e80a045dd /make/netkittelnet.mk
parentTurn on HAS_FPU by default. If soft float support is configured in the (diff)
downloadbuildroot-4f889ada561fbdffeefa1a8327d5b8939b021685.tar.gz
buildroot-4f889ada561fbdffeefa1a8327d5b8939b021685.tar.xz
buildroot-4f889ada561fbdffeefa1a8327d5b8939b021685.zip
automatically detect if we have a usable version of sed
installed. If not, we will now build our own version.
Diffstat (limited to 'make/netkittelnet.mk')
-rw-r--r--make/netkittelnet.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/make/netkittelnet.mk b/make/netkittelnet.mk
index b59f29fc9..401b885ca 100644
--- a/make/netkittelnet.mk
+++ b/make/netkittelnet.mk
@@ -19,9 +19,9 @@ netkittelnet-source: $(DL_DIR)/$(NETKITTELNET_SOURCE)
$(NETKITTELNET_DIR)/.unpacked: $(DL_DIR)/$(NETKITTELNET_SOURCE)
$(NETKITTELNET_CAT) $(DL_DIR)/$(NETKITTELNET_SOURCE) | tar -C $(BUILD_DIR) -xvf -
# use ANSI syntax
- sed -i -e "s/main()/main(void)/;" $(NETKITTELNET_DIR)/configure
+ $(SED) "s/main()/main(void)/;" $(NETKITTELNET_DIR)/configure
# Disable termcap support
- sed -i -e "s~\(.*termcap\.h.*\)~/* \1 */~;" $(NETKITTELNET_DIR)/telnetd/telnetd.c
+ $(SED) "s~\(.*termcap\.h.*\)~/* \1 */~;" $(NETKITTELNET_DIR)/telnetd/telnetd.c
# don't try to run cross compiled binaries while configuring things
cat $(NETKITTELNET_PATCH) | patch -p1 -d $(NETKITTELNET_DIR)
touch $(NETKITTELNET_DIR)/.unpacked
@@ -42,7 +42,7 @@ $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY): $(NETKITTELNET_DIR)/$(NETKITTELNET_
rm -f $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY)
cp $(NETKITTELNET_DIR)/$(NETKITTELNET_BINARY) $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY)
# Enable telnet in inetd
- sed -i -e "s~^#telnet.*~telnet\tstream\ttcp\tnowait\troot\t/usr/sbin/telnetd\t/usr/sbin/telnetd~;" $(TARGET_DIR)/etc/inetd.conf
+ $(SED) "s~^#telnet.*~telnet\tstream\ttcp\tnowait\troot\t/usr/sbin/telnetd\t/usr/sbin/telnetd~;" $(TARGET_DIR)/etc/inetd.conf
#$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(NETKITTELNET_DIR) install
#rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
# $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc