summaryrefslogtreecommitdiffstats
path: root/make/ntp.mk
diff options
context:
space:
mode:
authorEric Andersen2004-04-16 16:32:59 +0200
committerEric Andersen2004-04-16 16:32:59 +0200
commit3be179fa53b1aea973aefe79936fe14b3dcaabf1 (patch)
tree183b2b9f9a99e89e08172ba0768fb89739a48695 /make/ntp.mk
parentStick the cache in its own empty dir (diff)
downloadbuildroot-3be179fa53b1aea973aefe79936fe14b3dcaabf1.tar.gz
buildroot-3be179fa53b1aea973aefe79936fe14b3dcaabf1.tar.xz
buildroot-3be179fa53b1aea973aefe79936fe14b3dcaabf1.zip
Goetz Bock writes:
Hi Erik, as I was unable to find a buildroot mailing list, i just send this small patch to you. It's required to make ntp build on my system and only copy ntpdate into the target directory.
Diffstat (limited to 'make/ntp.mk')
-rw-r--r--make/ntp.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/make/ntp.mk b/make/ntp.mk
index f4cfaf365..b3f840a3e 100644
--- a/make/ntp.mk
+++ b/make/ntp.mk
@@ -3,12 +3,12 @@
# ntp
#
#############################################################
-NTP_SOURCE:=ntp-4.1.1.tar.gz
+NTP_SOURCE:=ntp-4.1.2.tar.gz
NTP_SITE:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4
-NTP_DIR:=$(BUILD_DIR)/ntp-4.1.1
+NTP_DIR:=$(BUILD_DIR)/ntp-4.1.2
NTP_CAT:=zcat
NTP_BINARY:=ntpdate/ntpdate
-NTP_TARGET_BINARY:=bin/ntpdate
+NTP_TARGET_BINARY:=usr/bin/ntpdate
$(DL_DIR)/$(NTP_SOURCE):
@@ -41,6 +41,7 @@ $(NTP_DIR)/.configured: $(NTP_DIR)/.unpacked
--infodir=/usr/info \
$(DISABLE_NLS) \
--with-shared \
+ --program-transform-name=s,,, \
);
touch $(NTP_DIR)/.configured
@@ -48,9 +49,7 @@ $(NTP_DIR)/$(NTP_BINARY): $(NTP_DIR)/.configured
$(MAKE) CC=$(TARGET_CC) -C $(NTP_DIR)
$(TARGET_DIR)/$(NTP_TARGET_BINARY): $(NTP_DIR)/$(NTP_BINARY)
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(NTP_DIR) install
- rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
- $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+ install -m 755 $(NTP_DIR)/$(NTP_BINARY) $(TARGET_DIR)/$(NTP_TARGET_BINARY)
ntp: uclibc $(TARGET_DIR)/$(NTP_TARGET_BINARY)