summaryrefslogtreecommitdiffstats
path: root/make/pcmcia.mk
diff options
context:
space:
mode:
authorEric Andersen2003-06-04 22:47:18 +0200
committerEric Andersen2003-06-04 22:47:18 +0200
commitef9d12c6cabe35b2fdab176c3d3490b109d391c1 (patch)
treeac65b579614cf14fcebbb808a17b6dda3ee6f371 /make/pcmcia.mk
parentSupport net-snmp for those into that sortof thing (diff)
downloadbuildroot-ef9d12c6cabe35b2fdab176c3d3490b109d391c1.tar.gz
buildroot-ef9d12c6cabe35b2fdab176c3d3490b109d391c1.tar.xz
buildroot-ef9d12c6cabe35b2fdab176c3d3490b109d391c1.zip
Cleanup pcmcia a bit (such as removing the X11 binary it installs)
and use the pcmcia default init script rather than including a default one in the target_skeleton.
Diffstat (limited to 'make/pcmcia.mk')
-rw-r--r--make/pcmcia.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/make/pcmcia.mk b/make/pcmcia.mk
index bf94fed85..187ea3ee3 100644
--- a/make/pcmcia.mk
+++ b/make/pcmcia.mk
@@ -41,7 +41,7 @@ $(PCMCIA_DIR)/.patched: $(PCMCIA_DIR)/.unpacked
touch $(PCMCIA_DIR)/.patched
$(PCMCIA_DIR)/.configured: $(PCMCIA_DIR)/.patched
- ( cd $(PCMCIA_DIR) ; ./Configure --kernel=$(LINUX_SOURCE_DIR) --noprompt \
+ ( cd $(PCMCIA_DIR) ; ./Configure --kernel=$(LINUX_DIR) --noprompt \
--rcdir=/etc --arch=$(ARCH) --trust --srctree --nocardbus \
--sysv --kcc=$(HOSTCC) --ucc=$(TARGET_CC) --ld=$(TARGET_CROSS)ld \
--target=$(TARGET_DIR))
@@ -74,7 +74,14 @@ $(TARGET_DIR)/sbin/cardmgr: $(PCMCIA_DIR)/cardmgr/cardmgr
rm -f $(TARGET_DIR)/usr/share/pnp.ids $(TARGET_DIR)/sbin/lspnp $(TARGET_DIR)/sbin/setpnp;
rm -f $(TARGET_DIR)/sbin/pcinitrd
rm -f $(TARGET_DIR)/sbin/probe
- cp $(SOURCE_DIR)/target_skeleton/etc/init.d/S30pcmcia $(TARGET_DIR)/etc/init.d/S30pcmcia
+ rm -f $(TARGET_DIR)/sbin/ide_info
+ rm -f $(TARGET_DIR)/sbin/scsi_info
+ rm -f $(TARGET_DIR)/sbin/ftl_check
+ rm -f $(TARGET_DIR)/sbin/ftl_format
+ rm -f $(TARGET_DIR)/usr/X11R6/bin/xcardinfo
+ rm -rf $(TARGET_DIR)/etc/sysconfig
+ cp $(PCMCIA_DIR)/etc/rc.pcmcia $(TARGET_DIR)/etc/init.d/S30pcmcia
+ rm -rf $(TARGET_DIR)/etc/pcmcia/cis
chmod a+x $(TARGET_DIR)/etc/init.d/S30pcmcia
chmod -R u+w $(TARGET_DIR)/etc/pcmcia/*