summaryrefslogtreecommitdiffstats
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard2012-01-18 15:54:55 +0100
committerPeter Korsgaard2012-01-18 16:02:51 +0100
commit1b07928aa647074f790a01f0302f241391b5c923 (patch)
tree8f7f552fea831f6482ca255f501e82650cfc3d22 /package/Makefile.autotools.in
parentxapp_mkfontdir: removed redundant HOST_FOO_DEPENDENCIES (diff)
downloadbuildroot-1b07928aa647074f790a01f0302f241391b5c923.tar.gz
buildroot-1b07928aa647074f790a01f0302f241391b5c923.tar.xz
buildroot-1b07928aa647074f790a01f0302f241391b5c923.zip
Only derrive HOST_FOO_DEPENDENCIES from FOO_DEPENDENCIES if not set, not nonempty
In make, ifndef VAR means if 'VAR is not set to the empty string', and NOT 'VAR is not defined', which meant that you couldn't specify empty FOO_HOST_DEPENDENCIES. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in7
1 files changed, 2 insertions, 5 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 495a07580..0f9b2c60f 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -203,12 +203,9 @@ endef
# This must be repeated from GENTARGETS_INNER, otherwise we get an empty
# _DEPENDENCIES if _AUTORECONF is YES. Also filter the result of _AUTORECONF
# away from the non-host rule
-ifndef $(2)_DEPENDENCIES
- ifdef $(3)_DEPENDENCIES
- $(2)_DEPENDENCIES = $(filter-out host-automake host-autoconf host-libtool,\
+$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool,\
$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
- endif
-endif
+
ifeq ($$($(2)_AUTORECONF),YES)
$(2)_PRE_CONFIGURE_HOOKS += AUTORECONF_HOOK