summaryrefslogtreecommitdiffstats
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorThomas Petazzoni2011-08-31 23:35:04 +0200
committerPeter Korsgaard2011-09-17 08:15:32 +0200
commit59a326b934737483531c49c99acda7874c72e335 (patch)
tree37535beb370ab735f84fe06ff641da3720211fce /package/Makefile.autotools.in
parentsupport: move libtool patches in support/libtool (diff)
downloadbuildroot-59a326b934737483531c49c99acda7874c72e335.tar.gz
buildroot-59a326b934737483531c49c99acda7874c72e335.tar.xz
buildroot-59a326b934737483531c49c99acda7874c72e335.zip
support: move patch-kernel.sh and rename it
The name "patch-kernel.sh" is a bit stupid, since this script is used to patch everything in Buildroot, not only kernel trees. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 90c892441..12c503827 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -152,11 +152,11 @@ define LIBTOOL_PATCH_HOOK
ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$$$i | \
sed -e 's/\([0-9].[0-9]*\).*/\1/' -e 's/\"//'`; \
if test $$$${ltmain_version} = '1.5'; then \
- toolchain/patch-kernel.sh $$$${i%/*} support/libtool buildroot-libtool-v1.5.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} support/libtool buildroot-libtool-v1.5.patch; \
elif test $$$${ltmain_version} = "2.2"; then\
- toolchain/patch-kernel.sh $$$${i%/*} support/libtool buildroot-libtool-v2.2.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} support/libtool buildroot-libtool-v2.2.patch; \
elif test $$$${ltmain_version} = "2.4"; then\
- toolchain/patch-kernel.sh $$$${i%/*} support/libtool buildroot-libtool-v2.4.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} support/libtool buildroot-libtool-v2.4.patch; \
fi \
done \
fi
@@ -177,11 +177,11 @@ define AUTORECONF_HOOK
for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$$$i | sed 's/\([0-9].[0-9]*\).*/\1/'`; \
if test $$$${ltmain_version} = "1.5"; then \
- toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v1.5.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} package buildroot-libtool-v1.5.patch; \
elif test $$$${ltmain_version} = "2.2"; then\
- toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v2.2.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} package buildroot-libtool-v2.2.patch; \
elif test $$$${ltmain_version} = "2.4"; then\
- toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v2.4.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} package buildroot-libtool-v2.4.patch; \
fi \
done \
fi