summaryrefslogtreecommitdiffstats
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorLionel Landwerlin2010-04-30 02:24:06 +0200
committerPeter Korsgaard2010-05-02 09:32:14 +0200
commite8b469b81fe06cbc01f2c00dfe11a2193c612327 (patch)
treeb7bc54c8bc964401257f69bd8a2bc4d49e7c05f7 /package/Makefile.autotools.in
parentpackage: add PKG_CONF_ENV variables to host packages (diff)
downloadbuildroot-e8b469b81fe06cbc01f2c00dfe11a2193c612327.tar.gz
buildroot-e8b469b81fe06cbc01f2c00dfe11a2193c612327.tar.xz
buildroot-e8b469b81fe06cbc01f2c00dfe11a2193c612327.zip
package: Force copy of .la files at the post install hook (readonly files might be problematic)
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 34aab77a2..b7a710359 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -201,7 +201,7 @@ ifndef $(2)_INSTALL_STAGING_CMDS
define $(2)_INSTALL_STAGING_CMDS
$$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_STAGING_OPT) -C $$($$(PKG)_SRCDIR)
for i in $$$$(find $(STAGING_DIR)/usr/lib* -name "*.la"); do \
- cp $$$$i $$$$i~; \
+ cp -f $$$$i $$$$i~; \
$$(SED) "s:\(['= ]\)/usr:\\1$(STAGING_DIR)/usr:g" $$$$i; \
done
endef