summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni2010-04-10 23:50:45 +0200
committerPeter Korsgaard2010-04-11 21:10:35 +0200
commit04ba0089a672863e333a2de6b19d9b77fd0b26c1 (patch)
treeefa1683cacdda6ad37f61b4acf2275f734e38dff /package/Makefile.in
parentGet rid of useless OpenMP related code (diff)
downloadbuildroot-04ba0089a672863e333a2de6b19d9b77fd0b26c1.tar.gz
buildroot-04ba0089a672863e333a2de6b19d9b77fd0b26c1.tar.xz
buildroot-04ba0089a672863e333a2de6b19d9b77fd0b26c1.zip
Get rid of the OPTIMIZE_FOR_CPU variable
This variable, together with the FIXME comment, has been added has part of Eric Andersen's « Major buildroot facelift, step one » commit that occured in October 2004. Since then, no real usage has been made of OPTIMIZE_FOR_CPU, and the initial intention has probably been lost in the memories of the implementors. Therefore, get rid of the variable, and just use $(ARCH) at the two locations the variable was used. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 43ff2ddad..983caf38e 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -109,8 +109,8 @@ TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
# Quotes are needed for spaces et al in path components.
TARGET_PATH="$(TOOLCHAIN_DIR)/bin:$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:$(PATH)"
-GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
-REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)
+GNU_TARGET_NAME=$(ARCH)-linux
+REAL_GNU_TARGET_NAME=$(ARCH)$(GNU_TARGET_SUFFIX)
TARGET_CROSS=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-
KERNEL_CROSS=$(TARGET_CROSS)
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)