summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-10-02 23:36:49 +0200
committerBernhard Reutner-Fischer2007-10-02 23:36:49 +0200
commit05195c3d000f080bc3103850158387578f7c2242 (patch)
tree018796092e8ced6db8294a18fda59826fe8f8315 /package/Makefile.in
parent- make sure that the target's usr/include dir exists when installing the headers (diff)
downloadbuildroot-05195c3d000f080bc3103850158387578f7c2242.tar.gz
buildroot-05195c3d000f080bc3103850158387578f7c2242.tar.xz
buildroot-05195c3d000f080bc3103850158387578f7c2242.zip
- default to mips I for mipsel and mips III for mips
- suggest some target flags for abi64
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 0c2abcb1d..903f46d6d 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -51,6 +51,10 @@ ifeq ($(findstring y,$(BR2_sparc_v9a)$(BR2_sparc64_v9a)$(BR2_sparc_v9b)$(BR2_spa
TARGET_CFLAGS+=-mvis
endif
+ifeq ($(findstring yy,$(BR2_mips)$(BR2_MIPS_ABI64)),yy)
+TARGET_CFLAGS+=-fno-pic -mno-abicalls
+endif
+
TARGET_CXXFLAGS=$(TARGET_CFLAGS)
# else it's an external toolchain