summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson2007-07-17 14:09:07 +0200
committerUlf Samuelsson2007-07-17 14:09:07 +0200
commit4705b600764c683e934da7db54f7971a3c647e8a (patch)
treee602010f4cf916d7a8f89b6737d42b49d0ad3e25 /package/Makefile.in
parentUpdate configure files for libdaemon (diff)
downloadbuildroot-4705b600764c683e934da7db54f7971a3c647e8a.tar.gz
buildroot-4705b600764c683e934da7db54f7971a3c647e8a.tar.xz
buildroot-4705b600764c683e934da7db54f7971a3c647e8a.zip
Ensure we use host 'make', even when building 'make' in buildroot
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 2fe658353..29c505835 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -1,8 +1,13 @@
-ifndef MAKE
-MAKE=make
+ifndef MAKE
+MAKE:=make
endif
-MAKE1:=$(MAKE) MAKE="$(firstword $(MAKE)) -j1"
-MAKE:=$(MAKE) -j$(BR2_JLEVEL)
+ifndef HOSTMAKE
+HOSTMAKE=$(MAKE)
+endif
+HOSTMAKE :=$(shell $(CONFIG_SHELL) -c "which $(HOSTMAKE)" || type -p $(HOSTMAKE) || echo make)
+
+MAKE1:=$(HOSTMAKE) MAKE="$(firstword $(HOSTMAKE)) -j1"
+MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
# Strip off the annoying quoting
ARCH:=$(strip $(subst ",, $(BR2_ARCH)))