summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorPeter Korsgaard2008-08-04 21:07:18 +0200
committerPeter Korsgaard2008-08-04 21:07:18 +0200
commit60b5eee76edfa153ef118d2788c74ac8da1497a0 (patch)
tree4edb8e2572e8803fc92d419920c32142f6b4fa3a /package/Makefile.in
parentbuildroot: remove trailing spaces (diff)
downloadbuildroot-60b5eee76edfa153ef118d2788c74ac8da1497a0.tar.gz
buildroot-60b5eee76edfa153ef118d2788c74ac8da1497a0.tar.xz
buildroot-60b5eee76edfa153ef118d2788c74ac8da1497a0.zip
package: global largefile CFLAGS handling
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 86df3f2e6..431ca8e78 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -80,6 +80,10 @@ ifeq ($(findstring yy,$(BR2_mips)$(BR2_MIPS_ABI64)),yy)
TARGET_CFLAGS+=-fno-pic -mno-abicalls
endif
+ifeq ($(BR2_LARGEFILE),y)
+TARGET_CFLAGS+=-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+endif
+
TARGET_CXXFLAGS=$(TARGET_CFLAGS)
# else it's an external toolchain