summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni2010-12-13 17:27:41 +0100
committerPeter Korsgaard2010-12-13 22:04:35 +0100
commit6b578c8d73b6403e3be8bddf611fb1059d7c2f4b (patch)
treede57da65f9460e3c9edb0599a859809384452580 /package/Makefile.in
parenttoolchain: remove toolchain-specific stripping (diff)
downloadbuildroot-6b578c8d73b6403e3be8bddf611fb1059d7c2f4b.tar.gz
buildroot-6b578c8d73b6403e3be8bddf611fb1059d7c2f4b.tar.xz
buildroot-6b578c8d73b6403e3be8bddf611fb1059d7c2f4b.zip
toolchain: rework C++ options
Instead of having BR2_GCC_CROSS_CXX and BR2_INSTALL_LIBSTDCPP, with BR2_GCC_CROSS_CXX not being visible (and therefore being useless), let's just keep BR2_INSTALL_LIBSTDCPP to enable C++ in the toolchain and install C++ libraries on the target. We also take that opportunity to make BR2_INSTALL_LIBSTDCPP an hidden option, which is selected by an option in Buildroot toolchain support or an option in External toolchain support, just as we did for other toolchain features. Some work definitely remains to be done : - The name BR2_INSTALL_LIBSTDCPP is ugly, but we keep it for the moment in order to avoid changing all packages. - We should clarify the other language-related options (Fortran, Java, Objective-C, etc.). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 36bd59f37..71c8dbc86 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -307,7 +307,7 @@ ifneq ($(BR2_INET_IPV6),y)
DISABLE_IPV6= --disable-ipv6
endif
-ifneq ($(BR2_GCC_CROSS_CXX),y)
+ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
TARGET_CONFIGURE_OPTS+=CXX=false
endif