summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson2009-01-18 11:51:53 +0100
committerUlf Samuelsson2009-01-18 11:51:53 +0100
commit6da70de5034ae3933c6d072378a8860078686200 (patch)
tree13db89b68591f78d408d5af49a0e88f0cba94f22 /package/Makefile.in
parentGetting rid of a bit more configure options that's been centralized. (diff)
downloadbuildroot-6da70de5034ae3933c6d072378a8860078686200.tar.gz
buildroot-6da70de5034ae3933c6d072378a8860078686200.tar.xz
buildroot-6da70de5034ae3933c6d072378a8860078686200.zip
The liboil Makefile will use "-mcpu=vfp" when building for ARM.
The VFP is only available for a few ARM CPUs at the moment, so this breaks the liboil build. A patch is available upstream which only enables "-mfpu=vfp" if "--enable-vfp" is given to "configure". Autotools needs to be run for liboil for this to take effect. A new configuration BR2_VFP_FLOAT is added to allow enabling vfp. If this is "yes", then "-mfpu=vfp" is added to CFLAGS.
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index a5be4d7b0..c430f8bf3 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -71,6 +71,10 @@ ifeq ($(BR2_SOFT_FLOAT),y)
TARGET_CFLAGS+=-msoft-float
endif
+ifeq ($(BR2_VFP_FLOAT),y)
+TARGET_CFLAGS+=-mfpu=vfp
+endif
+
# enable VIS for v9a and v9b
ifeq ($(findstring y,$(BR2_sparc_v9a)$(BR2_sparc64_v9a)$(BR2_sparc_v9b)$(BR2_sparc64_v9b)),y)
TARGET_CFLAGS+=-mvis