summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni2008-12-13 17:15:50 +0100
committerThomas Petazzoni2008-12-13 17:15:50 +0100
commit978d8dc53e997203c7244c9cb599247c68e1c72e (patch)
tree9f4eb8a611b5a862732e9e1169b78c7b07e0f958 /package/Makefile.in
parentmenuconfig: don't prepend CONFIG_ to symbols in help text (diff)
downloadbuildroot-978d8dc53e997203c7244c9cb599247c68e1c72e.tar.gz
buildroot-978d8dc53e997203c7244c9cb599247c68e1c72e.tar.xz
buildroot-978d8dc53e997203c7244c9cb599247c68e1c72e.zip
Another external toolchain support solution
* In toolchain/external-toolchain/ext-tool.mk, copy the contents of the sysroot directory to the staging dir. * In package/Makefile.in, add a --sysroot CFLAGS pointing to the staging dir * Remove the CFLAGS and LDFLAGS definition from TARGET_CONFIGURE_OPTS. I haven't investigated exactly why, but with these options, DirectFB fails to build because it cannot find PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP, even if DirectFB's Makefile properly sets -D_GNU_SOURCE. I have already sent this patch on December, 2nd to the mailing-list, but got no feedback. So let's commit and see what happens :-) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index fe1d6ad9f..66a8f695d 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -89,7 +89,7 @@ TARGET_CXXFLAGS=$(TARGET_CFLAGS)
# else it's an external toolchain
#########################################################################
else
-TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include -I$(TOOLCHAIN_EXTERNAL_PATH)/$(TOOLCHAIN_EXTERNAL_PREFIX)/include
+TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include -I$(TOOLCHAIN_EXTERNAL_PATH)/$(TOOLCHAIN_EXTERNAL_PREFIX)/include --sysroot $(STAGING_DIR)/
TARGET_CXXFLAGS=$(TARGET_CFLAGS)
TARGET_LDFLAGS=-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
endif
@@ -210,8 +210,6 @@ TARGET_CONFIGURE_OPTS=PATH=$(TARGET_PATH) \
AR="$(TARGET_AR)" \
AS="$(TARGET_AS)" \
LD="$(TARGET_LD)" \
- CFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
NM="$(TARGET_NM)" \
CC="$(TARGET_CC) $(TARGET_CFLAGS)" \
GCC="$(TARGET_CC) $(TARGET_CFLAGS)" \