summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-07-31 20:06:50 +0200
committerBernhard Reutner-Fischer2007-07-31 20:06:50 +0200
commitbbd251a07540477c37a48e92da3717e702255113 (patch)
tree1a8bb94b9d7630430201020a4ed8422dbb55c860 /package/Makefile.in
parent- lzma needs a CXX cross-compiler (diff)
downloadbuildroot-bbd251a07540477c37a48e92da3717e702255113.tar.gz
buildroot-bbd251a07540477c37a48e92da3717e702255113.tar.xz
buildroot-bbd251a07540477c37a48e92da3717e702255113.zip
- add possibility to select different flavours of strip (or none at all for debugging purposes)
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 17302527d..071635b58 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -131,9 +131,16 @@ endif
TARGET_CC=$(TARGET_CROSS)gcc
TARGET_CXX=$(TARGET_CROSS)g++
TARGET_RANLIB=$(TARGET_CROSS)ranlib
-STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
INSTALL=/usr/bin/install
-
+ifeq ($(BR2_STRIP_strip),y)
+STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+endif
+ifeq ($(BR2_STRIP_sstrip),y)
+STRIP=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip
+endif
+ifeq ($(BR2_STRIP_none),y)
+STRIP=true -Not_stripping
+endif
HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-e 's/sparc.*/sparc/' \