summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson2007-08-21 03:53:57 +0200
committerUlf Samuelsson2007-08-21 03:53:57 +0200
commite4ead9c13ccad1b89743fdd46e8675f45758aec3 (patch)
tree43202589730a8ecf12f01a429155e78be49ee76f /package/Makefile.in
parentReintroduce possibility to use old makefile for tiny-x as a test (diff)
downloadbuildroot-e4ead9c13ccad1b89743fdd46e8675f45758aec3.tar.gz
buildroot-e4ead9c13ccad1b89743fdd46e8675f45758aec3.tar.xz
buildroot-e4ead9c13ccad1b89743fdd46e8675f45758aec3.zip
Remove switches if sstrip is run
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 1589cf14b..e3d7f8301 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -138,9 +138,19 @@ TARGET_LDCONFIG=$(TARGET_CROSS)ldconfig
INSTALL=/usr/bin/install
ifeq ($(BR2_STRIP_strip),y)
STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+STRIP_DISCARD_ALL:=--discard-all
+STRIP_STRIP_UNNEEDED:=--strip-unneeded
+STRIP_STRIP_ALL:=--strip-all
+REMOVE_SECTION_COMMENT:=--remove-section=.comment
+REMOVE_SECTION_NOTE:=--remove-section=.note
endif
ifeq ($(BR2_STRIP_sstrip),y)
STRIP=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip
+STRIP_DISCARD_ALL:=
+STRIP_STRIP_UNNEEDED:=
+STRIP_STRIP_ALL:=
+REMOVE_SECTION_COMMENT:=
+REMOVE_SECTION_NOTE:=
endif
ifeq ($(BR2_STRIP_none),y)
STRIP=true -Not_stripping