summaryrefslogtreecommitdiffstats
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorThomas Petazzoni2011-07-05 21:54:11 +0200
committerPeter Korsgaard2011-07-10 22:24:56 +0200
commitc917550361feb0858e5cc479273f46af136d8347 (patch)
tree758b1da8c830d21ca04c03e9bda46cbd14c77fb8 /package/Makefile.package.in
parentuboot-mkimage: add target support (diff)
downloadbuildroot-c917550361feb0858e5cc479273f46af136d8347.tar.gz
buildroot-c917550361feb0858e5cc479273f46af136d8347.tar.xz
buildroot-c917550361feb0858e5cc479273f46af136d8347.zip
package: add support for post-download hooks
This will be needed for the Linux kernel package, which needs to download patches in a custom way. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 8b5657b2d..aa5c0d7e8 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -234,6 +234,7 @@ ifeq ($(DL_MODE),DOWNLOAD)
endif
$(if $($(PKG)_SOURCE),$(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_SOURCE)))
$(if $($(PKG)_PATCH),$(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_PATCH)))
+ $(foreach hook,$($(PKG)_POST_DOWNLOAD_HOOKS),$(call $(hook))$(sep))
ifeq ($(DL_MODE),DOWNLOAD)
$(Q)mkdir -p $(@D)
$(Q)touch $@
@@ -437,6 +438,7 @@ $(2)_EXTRACT_CMDS ?= \
$(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $$($(2)_DIR) $(TAR_OPTIONS) -)
# post-steps hooks
+$(2)_POST_DOWNLOAD_HOOKS ?=
$(2)_POST_EXTRACT_HOOKS ?=
$(2)_POST_PATCH_HOOKS ?=
$(2)_PRE_CONFIGURE_HOOKS ?=