summaryrefslogtreecommitdiffstats
path: root/package/avahi
diff options
context:
space:
mode:
authorThomas Petazzoni2010-09-01 17:10:57 +0200
committerThomas Petazzoni2010-09-12 19:24:58 +0200
commit28025091919e3e0dfb99a39e9f6afde46764b8ab (patch)
tree773f07a2151053c2ddaa55ba7ff54704d6a92a14 /package/avahi
parenttn5250: remove old-style hook usage and step override (diff)
downloadbuildroot-28025091919e3e0dfb99a39e9f6afde46764b8ab.tar.gz
buildroot-28025091919e3e0dfb99a39e9f6afde46764b8ab.tar.xz
buildroot-28025091919e3e0dfb99a39e9f6afde46764b8ab.zip
avahi: convert old-style hook to new-style hook
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/avahi.mk24
1 files changed, 18 insertions, 6 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 8e2d14f6e..e1bebd914 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -137,19 +137,31 @@ AVAHI_DEPENDENCIES += libintl
AVAHI_MAKE_OPT = LIBS=-lintl
endif
-$(eval $(call AUTOTARGETS,package,avahi))
-
-$(AVAHI_HOOK_POST_INSTALL):
+define AVAHI_REMOVE_INITSCRIPT
rm -rf $(TARGET_DIR)/etc/init.d/avahi-*
-ifeq ($(BR2_PACKAGE_AVAHI_AUTOIPD),y)
+endef
+
+AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_REMOVE_INITSCRIPT
+
+define AVAHI_INSTALL_AUTOIPD
rm -rf $(TARGET_DIR)/etc/dhcp3/
$(INSTALL) -D -m 0755 package/avahi/busybox-udhcpc-default.script $(TARGET_DIR)/usr/share/udhcpc/default.script
$(INSTALL) -m 0755 package/avahi/S05avahi-setup.sh $(TARGET_DIR)/etc/init.d/
rm -f $(TARGET_DIR)/var/lib/avahi-autoipd
$(INSTALL) -d -m 0755 $(TARGET_DIR)/var/lib
ln -sf /tmp/avahi-autoipd $(TARGET_DIR)/var/lib/avahi-autoipd
+endef
+
+ifeq ($(BR2_PACKAGE_AVAHI_AUTOIPD),y)
+AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_AUTOIPD
endif
-ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
+
+define AVAHI_INSTALL_DAEMON_INITSCRIPT
$(INSTALL) -m 0755 package/avahi/S50avahi-daemon $(TARGET_DIR)/etc/init.d/
+endef
+
+ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
+AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_DAEMON_INITSCRIPT
endif
- touch $@
+
+$(eval $(call AUTOTARGETS,package,avahi))