summaryrefslogtreecommitdiffstats
path: root/package/coreutils/coreutils.mk
diff options
context:
space:
mode:
authorMartin Banky2010-09-30 21:03:36 +0200
committerPeter Korsgaard2011-01-14 00:39:39 +0100
commit05c8c8eb5ae4f001e594f7c756cf118ca54ad1c6 (patch)
tree4248cd19dcf4ad18fdc10efd5e4aa821350075b1 /package/coreutils/coreutils.mk
parentcoreutils: changed/removed some of the configure environmental variables (diff)
downloadbuildroot-05c8c8eb5ae4f001e594f7c756cf118ca54ad1c6.tar.gz
buildroot-05c8c8eb5ae4f001e594f7c756cf118ca54ad1c6.tar.xz
buildroot-05c8c8eb5ae4f001e594f7c756cf118ca54ad1c6.zip
coreutils: add uname patch
On linux platforms, grok /proc/cpuinfo for the CPU/vendor info. Signed-off-by: Martin Banky <Martin.Banky@gmail.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/coreutils/coreutils.mk')
-rw-r--r--package/coreutils/coreutils.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index ae8863f5d..d934ae896 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -54,6 +54,14 @@ COREUTILS_CONF_OPT = --disable-rpath \
--disable-dependency-tracking \
--enable-install-program=hostname
+define COREUTILS_TOUCH_UNAME_C
+ # ensure uname.c file's timestamp does not change,
+ # so help2man does not run
+ touch -d '2010-01-01' $(@D)/src/uname.c
+endef
+
+COREUTILS_POST_PATCH_HOOKS += COREUTILS_TOUCH_UNAME_C
+
define COREUTILS_POST_INSTALL
# some things go in root rather than usr
for f in $(COREUTILS_BIN_PROGS); do \