summaryrefslogtreecommitdiffstats
path: root/package/customize
diff options
context:
space:
mode:
authorUlf Samuelsson2007-07-16 09:55:50 +0200
committerUlf Samuelsson2007-07-16 09:55:50 +0200
commit06cc62f9cfbe43e9d31a07667a6af905b5f34a42 (patch)
treeaf4e7883bca87fed84ea981f31c1686d8d4ec161 /package/customize
parentUse correct script to init lighttpd (diff)
downloadbuildroot-06cc62f9cfbe43e9d31a07667a6af905b5f34a42.tar.gz
buildroot-06cc62f9cfbe43e9d31a07667a6af905b5f34a42.tar.xz
buildroot-06cc62f9cfbe43e9d31a07667a6af905b5f34a42.zip
Get rid of repeated copy of 'customize'
Diffstat (limited to 'package/customize')
-rw-r--r--package/customize/customize.mk19
1 files changed, 17 insertions, 2 deletions
diff --git a/package/customize/customize.mk b/package/customize/customize.mk
index ed50f8f3a..4f8e4b27d 100644
--- a/package/customize/customize.mk
+++ b/package/customize/customize.mk
@@ -5,8 +5,23 @@
#############################################################
CUST_DIR:=package/customize/source
-customize:
- -cp -af $(CUST_DIR)/* $(TARGET_DIR)/
+$(BUILD_DIR)/.customize:
+ rm -f $(PROJECT_BUILD_DIR)/series
+ (cd $(CUST_DIR) ; \
+ /bin/ls -d * > $(PROJECT_BUILD_DIR)/series || \
+ touch $(PROJECT_BUILD_DIR)/series )
+ for f in `cat $(PROJECT_BUILD_DIR)/series` ; do \
+ cp -af $(CUST_DIR)/$$f $(TARGET_DIR)/$$f ; \
+ done
+ rm -f $(PROJECT_BUILD_DIR)/series
+ touch $@
+
+customize: $(BUILD_DIR)/.customize
+
+customize-clean:
+ rm -f $(BUILD_DIR)/.customize
+
+.PHONY: customize
#############################################################
#
# Toplevel Makefile options