summaryrefslogtreecommitdiffstats
path: root/package/dbus
diff options
context:
space:
mode:
authorPeter Korsgaard2009-01-30 14:54:42 +0100
committerPeter Korsgaard2009-01-30 14:54:42 +0100
commite4051615c4ba14b75bd52dd03db7914f8a0a5c76 (patch)
treeae9e4efc0f16838e972d4b1d03765cab46453066 /package/dbus
parenttoolchain: fix up GNU_TARGET_NAME link and target_utils location (diff)
downloadbuildroot-e4051615c4ba14b75bd52dd03db7914f8a0a5c76.tar.gz
buildroot-e4051615c4ba14b75bd52dd03db7914f8a0a5c76.tar.xz
buildroot-e4051615c4ba14b75bd52dd03db7914f8a0a5c76.zip
dbus: revert r25156 (Fix dbus dependency on libxml2, without rebuild, works but may need refinement)
As discussed on the list - Too complicated and wrong.
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index b54f8da00..c98827ba3 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -15,16 +15,16 @@ ifeq ($(BR2_DBUS_EXPAT),y)
DBUS_XML:=expat
# depend on the exact library file instead of expat so dbus isn't always
# considered out-of-date
-DBUS_XML_DEP:=$(STAGING_DIR)/usr/lib/libexpat.so.1
+DBUS_XML_DEP_LIB:=$(STAGING_DIR)/usr/lib/libexpat.so.1
else
DBUS_XML:=libxml
# Makefile.autotools.in unfortunately has broken dependency handling,
# so we cannot do the same for libxml2
-DBUS_XML_DEP:=$(LIBXML2_HOOK_POST_INSTALL)
+DBUS_XML_DEP_LIB:=$(LIBXML2_HOOK_POST_INSTALL)
#libxml2-install-staging
endif
-
+DBUS_XML_DEP:=$(DBUS_XML_DEP_LIB)
$(DL_DIR)/$(DBUS_SOURCE):
$(call DOWNLOAD,$(DBUS_SITE),$(DBUS_SOURCE))
@@ -37,7 +37,6 @@ $(DBUS_DIR)/.unpacked: $(DL_DIR)/$(DBUS_SOURCE)
$(DBUS_DIR)/.configured: $(DBUS_DIR)/.unpacked $(DBUS_XML_DEP)
(cd $(DBUS_DIR); rm -rf config.cache; \
- echo "dbus is depending on $(DBUS_XML_DEP)"; \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
ac_cv_have_abstract_sockets=yes \