summaryrefslogtreecommitdiffstats
path: root/package/fbv/fbv.mk
diff options
context:
space:
mode:
authorArn R2012-06-15 00:10:18 +0200
committerPeter Korsgaard2012-06-16 22:34:56 +0200
commit0e41f5628b98f9827236a8499e45aefd40282623 (patch)
treecc530c4df9349fb6b65cfbcd951af91fb396f69f /package/fbv/fbv.mk
parente2fsprogs: bump to 1.42.4 (diff)
downloadbuildroot-0e41f5628b98f9827236a8499e45aefd40282623.tar.gz
buildroot-0e41f5628b98f9827236a8499e45aefd40282623.tar.xz
buildroot-0e41f5628b98f9827236a8499e45aefd40282623.zip
fbv: Allow selection of supported image formats.
This removes fbv's compulsory dependency on either libpng and/or libjpeg and/or libungif. The user can choose which compressed image format's fbv should support. By default PNG, JPEG and GIF are selected. Note that BMP format support will still always be included. [Peter: Drop (unneeded) png specific libs] Signed-off-by: Arn R <arnerro@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fbv/fbv.mk')
-rw-r--r--package/fbv/fbv.mk21
1 files changed, 19 insertions, 2 deletions
diff --git a/package/fbv/fbv.mk b/package/fbv/fbv.mk
index 855a0d42c..7db68022b 100644
--- a/package/fbv/fbv.mk
+++ b/package/fbv/fbv.mk
@@ -7,7 +7,24 @@ FBV_VERSION:=1.0b
FBV_SOURCE:=fbv-$(FBV_VERSION).tar.gz
FBV_SITE:=http://s-tech.elsat.net.pl/fbv
-FBV_DEPENDENCIES = libpng jpeg libungif
+### image format dependencies and configure options
+FBV_DEPENDENCIES = # empty
+FBV_CONFIGURE_OPTS = # empty
+ifeq ($(BR2_PACKAGE_FBV_PNG),y)
+FBV_DEPENDENCIES += libpng
+else
+FBV_CONFIGURE_OPTS += --without-libpng
+endif
+ifeq ($(BR2_PACKAGE_FBV_JPEG),y)
+FBV_DEPENDENCIES += jpeg
+else
+FBV_CONFIGURE_OPTS += --without-libjpeg
+endif
+ifeq ($(BR2_PACKAGE_FBV_GIF),y)
+FBV_DEPENDENCIES += libungif
+else
+FBV_CONFIGURE_OPTS += --without-libungif
+endif
#fbv donesn't support cross-compilation
define FBV_CONFIGURE_CMDS
@@ -16,7 +33,7 @@ define FBV_CONFIGURE_CMDS
$(TARGET_CONFIGURE_ARGS) \
./configure \
--prefix=/usr \
- --libs="-lz -lm" \
+ $(FBV_CONFIGURE_OPTS) \
)
endef