summaryrefslogtreecommitdiffstats
path: root/package/fluxbox/fluxbox.mk
diff options
context:
space:
mode:
authorYegor Yefremov2011-10-10 11:21:58 +0200
committerPeter Korsgaard2011-12-07 21:11:57 +0100
commitb87f2942f0ab9e8ee003cac08a172d2a51a3535f (patch)
tree6bab0a8951909545e05f1371f108d5d5695e688b /package/fluxbox/fluxbox.mk
parentwpa_supplicant: add CONFIG_AP support (diff)
downloadbuildroot-b87f2942f0ab9e8ee003cac08a172d2a51a3535f.tar.gz
buildroot-b87f2942f0ab9e8ee003cac08a172d2a51a3535f.tar.xz
buildroot-b87f2942f0ab9e8ee003cac08a172d2a51a3535f.zip
fluxbox: add xsession profile
add .xsession profile to get fluxbox being started automatically by XDM. [Peter: Only install if not available in skeleton, use install -D, Make it an executable script and don't hide it] Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fluxbox/fluxbox.mk')
-rw-r--r--package/fluxbox/fluxbox.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/fluxbox/fluxbox.mk b/package/fluxbox/fluxbox.mk
index 85a8eae41..5a123f0e9 100644
--- a/package/fluxbox/fluxbox.mk
+++ b/package/fluxbox/fluxbox.mk
@@ -13,4 +13,11 @@ FLUXBOX_CONF_OPT = --x-includes=$(STAGING_DIR)/usr/include/X11 \
FLUXBOX_DEPENDENCIES = xlib_libX11 $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+define FLUXBOX_INSTALL_XSESSION_FILE
+ [ -f $(TARGET_DIR)/root/.xsession ] || $(INSTALL) -m 0755 -D \
+ package/fluxbox/xsession $(TARGET_DIR)/root/.xsession
+endef
+
+FLUXBOX_POST_INSTALL_TARGET_HOOKS += FLUXBOX_INSTALL_XSESSION_FILE
+
$(eval $(call AUTOTARGETS))