summaryrefslogtreecommitdiffstats
path: root/package/games/prboom/prboom.mk
diff options
context:
space:
mode:
authorPeter Korsgaard2010-10-14 20:31:04 +0200
committerPeter Korsgaard2010-10-14 20:32:34 +0200
commitc4e6bc74de5ac03e74b797bbcd088977f166d484 (patch)
treedfb042e47af998cec560692dd9de9ffb5dfa8abf /package/games/prboom/prboom.mk
parentprboom: bump version (diff)
downloadbuildroot-c4e6bc74de5ac03e74b797bbcd088977f166d484.tar.gz
buildroot-c4e6bc74de5ac03e74b797bbcd088977f166d484.tar.xz
buildroot-c4e6bc74de5ac03e74b797bbcd088977f166d484.zip
prboom: fix png support
Ensure libpng gets built before prboom so configure finds it, and fix build with libpng 1.4.x (NULL defines removed). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/games/prboom/prboom.mk')
-rw-r--r--package/games/prboom/prboom.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/games/prboom/prboom.mk b/package/games/prboom/prboom.mk
index 651118cab..a8c7f6548 100644
--- a/package/games/prboom/prboom.mk
+++ b/package/games/prboom/prboom.mk
@@ -7,6 +7,10 @@ PRBOOM_VERSION = 2.5.0
PRBOOM_CONF_ENV = ac_cv_type_uid_t=yes
PRBOOM_DEPENDENCIES = sdl SDL_net sdl_mixer
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+PRBOOM_DEPENDENCIES += libpng
+endif
+
PRBOOM_CONF_OPT = \
--oldincludedir=$(STAGING_DIR)/usr/include \
--with-sdl-prefix=$(STAGING_DIR)/usr \