summaryrefslogtreecommitdiffstats
path: root/package/grep
diff options
context:
space:
mode:
authorPeter Korsgaard2010-12-25 22:33:20 +0100
committerPeter Korsgaard2010-12-25 22:33:20 +0100
commit28f77123de67834dee88d2c092c0f4b0770d6af2 (patch)
tree8664132be0f8dbd58c48354cf29c65f917f04f08 /package/grep
parentpackage/games: remove magiccube4d (diff)
downloadbuildroot-28f77123de67834dee88d2c092c0f4b0770d6af2.tar.gz
buildroot-28f77123de67834dee88d2c092c0f4b0770d6af2.tar.xz
buildroot-28f77123de67834dee88d2c092c0f4b0770d6af2.zip
grep: fix build when libiconv is enabled
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/grep')
-rw-r--r--package/grep/grep.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index e323b1de9..bfc911663 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -9,4 +9,10 @@ GREP_SITE = $(BR2_GNU_MIRROR)/grep
GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
+# link with iconv if enabled
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+GREP_CONF_ENV += LIBS=-liconv
+GREP_DEPENDENCIES += libiconv
+endif
+
$(eval $(call AUTOTARGETS,package,grep))