summaryrefslogtreecommitdiffstats
path: root/package/libidn
diff options
context:
space:
mode:
authorDaniel Laird2009-01-13 17:36:16 +0100
committerDaniel Laird2009-01-13 17:36:16 +0100
commit2f211c877864f66c9eab3422dc60af4171394010 (patch)
treeeda848d0a0653c2a764773a589ddaaaaa290d083 /package/libidn
parentbuildroot: mark alpha as broken (diff)
downloadbuildroot-2f211c877864f66c9eab3422dc60af4171394010.tar.gz
buildroot-2f211c877864f66c9eab3422dc60af4171394010.tar.xz
buildroot-2f211c877864f66c9eab3422dc60af4171394010.zip
package/libidn: Add a new package (required by later WebKits...)
GNU Libidn is a fully documented implementation of the Stringprep, Punycode and IDNA specifications. Libidn's purpose is to encode and decode internationalized domain names. The native C, C# and Java libraries are available under the GNU Lesser General Public License version 2.1 or later. Not quite sure I've put it in the correct menu but it will work. Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
Diffstat (limited to 'package/libidn')
-rw-r--r--package/libidn/Config.in6
-rw-r--r--package/libidn/libidn.mk14
2 files changed, 20 insertions, 0 deletions
diff --git a/package/libidn/Config.in b/package/libidn/Config.in
new file mode 100644
index 000000000..d92185dfa
--- /dev/null
+++ b/package/libidn/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBIDN
+ bool "libidn"
+ help
+ http://www.gnu.org/software/libidn/
+ Libidn's purpose is to encode and decode internationalized domain names.
+
diff --git a/package/libidn/libidn.mk b/package/libidn/libidn.mk
new file mode 100644
index 000000000..e2d73f660
--- /dev/null
+++ b/package/libidn/libidn.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# libidn
+#
+#############################################################
+LIBIDN_VERSION = 1.9
+LIBIDN_SOURCE = libidn-$(LIBIDN_VERSION).tar.gz
+LIBIDN_SITE = http://ftp.gnu.org/gnu/libidn/
+LIBIDN_INSTALL_STAGING = YES
+LIBIDN_INSTALL_TARGET = YES
+LIBIDN_CONF_OPT = --enable-shared
+LIBIDN_DEPENDENCIES = uclibc pkgconfig gettext $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
+$(eval $(call AUTOTARGETS,package,libidn))