summaryrefslogtreecommitdiffstats
path: root/package/libxml2
diff options
context:
space:
mode:
authorUlf Samuelsson2007-07-17 17:17:42 +0200
committerUlf Samuelsson2007-07-17 17:17:42 +0200
commitff2adceaa2b04a1a7c6a4f7ffbd81c59de7341cb (patch)
treeb584d4bffa342726d388263b91c52ad1cfc107c9 /package/libxml2
parentAdd 'linux26-modules' target to allow external drivers to be built with the k... (diff)
downloadbuildroot-ff2adceaa2b04a1a7c6a4f7ffbd81c59de7341cb.tar.gz
buildroot-ff2adceaa2b04a1a7c6a4f7ffbd81c59de7341cb.tar.xz
buildroot-ff2adceaa2b04a1a7c6a4f7ffbd81c59de7341cb.zip
Copy libxml2 headers to staging_dir (and possibly target_dir)
Diffstat (limited to 'package/libxml2')
-rw-r--r--package/libxml2/libxml2.mk19
1 files changed, 15 insertions, 4 deletions
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 2264e2f81..0e6fc2d4c 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -46,11 +46,20 @@ $(TARGET_DIR)/usr/lib/libxml2.so: $(STAGING_DIR)/usr/lib/libxml2.so
$(TARGET_DIR)/usr/lib/libxml2.a: $(STAGING_DIR)/usr/lib/libxml2.so
mkdir -p $(TARGET_DIR)/usr/include
cp -dpf $(STAGING_DIR)/usr/lib/libxml2.*a $(TARGET_DIR)/usr/lib/
-# cp -dpf $(STAGING_DIR)/usr/include/mad.h $(TARGET_DIR)/usr/include/
+# cp -dpf $(STAGING_DIR)/usr/include/libxml $(TARGET_DIR)/usr/include/
-libxml2: uclibc $(TARGET_DIR)/usr/lib/libxml2.so
+libxml2: uclibc $(TARGET_DIR)/usr/lib/libxml2.so libxml2-headers
-libxml2-headers: $(TARGET_DIR)/usr/lib/libxml2.a
+$(STAGING_DIR)/usr/include/libxml: $(TARGET_DIR)/usr/lib/libxml2.a
+ cp -af $(LIBXML2_DIR)/include/libxml $(STAGING_DIR)/usr/include/libxml2
+
+$(TARGET_DIR)/usr/include: libxml2-headers
+ cp -af $(LIBXML2_DIR)/include/libxml $(TARGET_DIR)/usr/include/libxml2
+
+
+libxml2-headers: $(STAGING_DIR)/usr/include/libxml2
+
+libxml2-target-headers: $(TARGET_DIR)/usr/include/libxml2
libxml2-source: $(DL_DIR)/$(LIBXML2_SOURCE)
@@ -64,6 +73,8 @@ libxml2-clean:
libxml2-dirclean:
rm -rf $(LIBXML2_DIR)
+
+.PHONY: libxml2-headers libxml2-target-headers
#############################################################
#
# Toplevel Makefile options
@@ -73,5 +84,5 @@ ifeq ($(strip $(BR2_PACKAGE_LIBXML2)),y)
TARGETS+=libxml2
endif
ifeq ($(strip $(BR2_PACKAGE_LIBXML2_TARGET_HEADERS)),y)
-TARGETS+=libxml2-headers
+TARGETS+=libxml2-target-headers
endif